Intermittent test_click.py test_click.TestClick.testClickingALinkMadeUpOfNumbersIsHandledCorrectly | InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed? | followed by hundreds of other failures

RESOLVED WORKSFORME

Status

Testing
Marionette
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Trunk
All
Gonk (Firefox OS)
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=29102514&tree=B2g-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=29100261&tree=B2g-Inbound
using slave: talos-r3-fed-040
using slave: talos-r3-fed-072



14:57:05     INFO -  TEST-START test_click.py
14:57:14     INFO -  testClickingALinkMadeUpOfNumbersIsHandledCorrectly (test_click.TestClick) ... ERROR
14:57:14     INFO -  ERROR
14:57:15     INFO -  test_click (test_click.TestClick) ... ERROR
14:57:16     INFO -  START LOG:
14:57:16     INFO -  Error getting log: [Errno 32] Broken pipe
14:57:16     INFO -  END LOG:
14:57:16     INFO -  ======================================================================
14:57:16     INFO -  ERROR: None
14:57:16     INFO -  ----------------------------------------------------------------------
14:57:16     INFO -  Traceback (most recent call last):
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 132, in run
14:57:16     INFO -      testMethod()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_click.py", line 20, in testClickingALinkMadeUpOfNumbersIsHandledCorrectly
14:57:16     INFO -      self.marionette.navigate(test_html)
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 861, in navigate
14:57:16     INFO -      response = self._send_message('goUrl', 'ok', value=url)
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 557, in _send_message
14:57:16     INFO -      response = self.client.send(message)
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 95, in send
14:57:16     INFO -      response = self.receive()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 58, in receive
14:57:16     INFO -      status=ErrorCodes.INVALID_RESPONSE)
14:57:16    ERROR -  TEST-UNEXPECTED-FAIL | test_click.py test_click.TestClick.testClickingALinkMadeUpOfNumbersIsHandledCorrectly | InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed?
14:57:16     INFO -  ======================================================================
14:57:16     INFO -  ERROR: None
14:57:16     INFO -  ----------------------------------------------------------------------
14:57:16     INFO -  Traceback (most recent call last):
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 162, in run
14:57:16     INFO -      self.tearDown()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 307, in tearDown
14:57:16     INFO -      self.marionette.set_context("content")
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 798, in set_context
14:57:16     INFO -      return self._send_message('setContext', 'ok', value=context)
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 557, in _send_message
14:57:16     INFO -      response = self.client.send(message)
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 95, in send
14:57:16     INFO -      response = self.receive()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 58, in receive
14:57:16     INFO -      status=ErrorCodes.INVALID_RESPONSE)
14:57:16    ERROR -  TEST-UNEXPECTED-FAIL | test_click.py test_click.TestClick.testClickingALinkMadeUpOfNumbersIsHandledCorrectly | InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed?
14:57:16     INFO -  ======================================================================
14:57:16     INFO -  ERROR: None
14:57:16     INFO -  ----------------------------------------------------------------------
14:57:16     INFO -  Traceback (most recent call last):
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 123, in run
14:57:16     INFO -      self.setUp()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 301, in setUp
14:57:16     INFO -      CommonTestCase.setUp(self)
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 236, in setUp
14:57:16     INFO -      self.marionette.start_session()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 676, in start_session
14:57:16     INFO -      self.session = self._send_message('newSession', 'value')
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 557, in _send_message
14:57:16     INFO -      response = self.client.send(message)
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 85, in send
14:57:16     INFO -      self.connect()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 73, in connect
14:57:16     INFO -      hello = self.receive()
14:57:16     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 58, in receive
14:57:16     INFO -      status=ErrorCodes.INVALID_RESPONSE)
14:57:16    ERROR -  TEST-UNEXPECTED-FAIL | test_click.py test_click.TestClick.test_click | InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed?
14:57:16     INFO -  ----------------------------------------------------------------------
14:57:16     INFO -  Ran 2 tests in 10.792s
14:57:16  WARNING -  FAILED (errors=3)
14:57:16     INFO -  TEST-START test_selected.py
14:57:16     INFO -  test_selected (test_selected.TestSelected) ... ERROR
14:57:17     INFO -  ======================================================================
14:57:17     INFO -  ERROR: None
14:57:17     INFO -  ----------------------------------------------------------------------
14:57:17     INFO -  Traceback (most recent call last):
14:57:17     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 123, in run
14:57:17     INFO -      self.setUp()
14:57:17     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 301, in setUp
14:57:17     INFO -      CommonTestCase.setUp(self)
14:57:17     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 236, in setUp
14:57:17     INFO -      self.marionette.start_session()
14:57:17     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 676, in start_session
14:57:17     INFO -      self.session = self._send_message('newSession', 'value')
14:57:17     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 557, in _send_message
14:57:17     INFO -      response = self.client.send(message)
14:57:17     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 95, in send
14:57:17     INFO -      response = self.receive()
14:57:17     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/client.py", line 58, in receive
14:57:17     INFO -      status=ErrorCodes.INVALID_RESPONSE)
14:57:17    ERROR -  TEST-UNEXPECTED-FAIL | test_selected.py test_selected.TestSelected.test_selected | InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed?
14:57:17     INFO -  ----------------------------------------------------------------------
14:57:17     INFO -  Ran 1 test in 0.777s
14:57:17  WARNING -  FAILED (errors=1)


Followed by hundreds of other failures...

I'd say it's a one-off, but it happened twice on the same push...
This is a crash in the main B2G process:

15:01:00    ERROR -  10-14 21:57:14.667    45    45 F libc    : Fatal signal 11 (SIGSEGV) at 0x0000002d (code=-6)
15:01:00    ERROR -  This usually indicates the B2G process has crashed

If it continues to occur, I'll escalate.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Duplicate of this bug: 919569
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
If we can get stacks for the gecko crash here, it'll help track down the problem (especially due to the low rate of reproduction locally).
Depends on: 866937
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
This seems to have taken care of itself, or morphed into a different bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.