[Buri][TOR][Email]Can't see the error message that says email sending failed.

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
5 years ago
7 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

72.55 KB, application/x-zip-compressed
Details
79.89 KB, application/x-zip-compressed
Details
85.20 KB, image/png
Details
(Reporter)

Description

5 years ago
Firefox os  v1.1
 Mozilla build ID:20130916041201
 
 Created an attachment (id=536183)
 logcat.log
 
 DEFECT DESCRIPTION:
 Can't see the error message that says email sending failed.
 
 REPRODUCING PROCEDURES:
 I have sent many mails now with different settings but I have *not* seen the error message that says email sending failed. I cannot reproduce this. (I know I saw it once yesterday, but I am pretty sure that was not with the 3G only setting)
 Twice the app hanged, and the mail never arrived where it should have, but I have not seen the error Hungary reported.
 
 EXPECTED BEHAVIOUR:
 Can see the error message that says email sending failed.
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 high
 REPRODUCING RATE:
 5/5
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 816936 [details]
logcat.log
(Reporter)

Comment 3

5 years ago
Clone from brother
(Reporter)

Comment 4

5 years ago
Created attachment 816937 [details]
new logcat.log
Our output in 'adb logcat' is not really sufficient to understand what's happening.  A secret debug mode log (https://wiki.mozilla.org/Gaia/Email/SecretDebugMode) may shed more light.

The first attachment (https://bugzilla.mozilla.org/attachment.cgi?id=816936) shows some concerning stuff in the log; an access denied failure to access an object and a bunch of AMD module-load failure.  Not sure what's going on there; maybe there was an uplift to the v1.1 branch in use that shouldn't have been uplifted?

Second attachment doesn't have anything suspicious in it, but again, we just don't log a lot for sending.

Updated

5 years ago
Summary: [Buri][Email]Can't see the error message that says email sending failed. → [Buri][TOR][Email]Can't see the error message that says email sending failed.
QA Wanted - Can someone try testing this to see if they can reproduce this?
Keywords: qawanted
Note for qawanted testing - be sure to test this with a TCL 1.1 partner build & Buri 1.1 Mozilla RIL for comparison.

Comment 8

5 years ago
Created attachment 818607 [details]
screenshot

Buri US_20130930 partner build 
SIM - AT&T
Cell&Data Settings - 3G Only
WiFi - Off

Had a few failed emails (due to a poor network connection), did get the notification when sending failed - see the screenshot

Build ID: 20130930155636
Gecko: N/A
Gaia: f85fffbb33a3c88cb993d2b4abd3f29b88bb527d
Platform Version: 18.1

Keep trying to repro failing sending emails on Mozilla v1.1 to see the behavior, will provide with results once get it to repro.

Comment 9

5 years ago
It turned out that notification mentioned in comment 8 appears any time when user is unable to send email due to a network issues or if the airplane mode is enabled. I get same notifications on both partner builds and Mozilla v1.1 builds.

I assume sending email failure described in comment 0 can be a different nature, and so might be handled differently. I've not experienced any other failures except of the network ones during my few good hours of testing around, so can only prove that those ones are handled with the error messages.

Buri v1.1 Mozilla RIL
Build ID: 20131015041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/4bfd6a51cd05
Gaia: 680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
Platform Version: 18.1
Keywords: qawanted

Updated

3 years ago
Blocks: 1258652

Comment 10

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.