persistant http connections

VERIFIED DUPLICATE of bug 92224

Status

()

VERIFIED DUPLICATE of bug 92224
18 years ago
18 years ago

People

(Reporter: asmodai, Assigned: neeti)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.2) Gecko/20010703
BuildID:    0000000000

I apologise in advance for the sheer lack of real data or steps to retrace the
problem, but I should bring this under the attention of people.

After visiting sites and getting flooded with pop-up windows on some sites (like
what happens sometimes when logging into planetarion.com) and leaving the
browser open on a site (like www.freebsd.org) only, after killing the pop-ups,
it seems that some http connection remains with the host of the pop-up window. 
In my case tcpdump showed that brandy.fortunecity.com was sending me a
continuous stream of data, about 3-4 k/s all from the http port.

Closing mozilla solved this problem.

Sample tcpdump:

13:39:05.979390 a96180.upc-a.chello.nl.3979 > brandy.fortunecity.com.http: P
1:721(720) ack 1 win 65535 (DF) (ttl 63, id 8492)
13:39:06.210757 brandy.fortunecity.com.http > a96180.upc-a.chello.nl.3979: .
1:1(0) ack 721 win 8760 (DF) (ttl 233, id 55581)
13:39:06.261239 brandy.fortunecity.com.http > a96180.upc-a.chello.nl.3979: F
1:1(0) ack 721 win 8760 (DF) (ttl 233, id 55582)
13:39:06.261965 a96180.upc-a.chello.nl.3979 > brandy.fortunecity.com.http: .
721:721(0) ack 2 win 65535 (DF) (ttl 63, id 8493)
13:39:06.262399 a96180.upc-a.chello.nl.3979 > brandy.fortunecity.com.http: F
721:721(0) ack 2 win 65535 (DF) (ttl 63, id 8494)
13:39:06.262718 a96180.upc-a.chello.nl.3980 > brandy.fortunecity.com.http: S
1287085769:1287085769(0) win 65535 <mss 1460,nop,wscale 1,nop,nop,timestamp
31773433 0> (DF) (ttl 63, id 8495)
13:39:06.376921 brandy.fortunecity.com.http > a96180.upc-a.chello.nl.3979: .
2:2(0) ack 722 win 8760 (DF) (ttl 233, id 55583)
13:39:06.377562 brandy.fortunecity.com.http > a96180.upc-a.chello.nl.3980: S
4226905356:4226905356(0) ack 1287085770 win 8760 <mss 1460> (DF) (ttl 233, id 55584)
It looks as if the supporting network code in mozilla hangs in a weird state. 
The funny thing is that netstat didn't show any persistant connections to/from
that host.

[gotta love wmnet monitoring your NIC interface in a dockapp]

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. No idea yet, as soon as I can I will report it.
2. It has happened to me before though, but I couldn't trace it back then to
what was causing it.
3.

Expected Results:  I think the connection wasn't cleared from the internal
connection state.  But that's just guessing, I really have no idea how the
sources of Mozilla are build up and I don't have a desire to delve into it,
since I have enough Open Source to hack as it stands. :)

FreeBSD 4.3-STABLE, no special hacks or whatever.

Compiled mozilla 0.9.2 from the ports/www/mozilla directory.
-> Networking:http
Component: Browser-General → Networking: HTTP
reassign and CC darin
Assignee: asa → neeti
QA Contact: doronr → benc

Comment 3

18 years ago
The server is not sending any data at all.

--->telnet brandy.fortunecity.com 80
Trying 204.198.135.22...
Connected to brandy.fortunecity.com.
Escape character is ^].
GET / HTTP/1.1
Host: brandy.fortunecity.com

Connection closed by foreign host.


It looks like mozilla is retrying the connection on different ports. 
Could this be related to bug 92224?
(Reporter)

Comment 4

18 years ago
Yes,

I tested the URL in that Bug Report and I got the same sort of problems as I
described.

I think this could be marked as duplicate of that Bug Report.  [Which I just did]
Thanks for spotting the other Bug Report, I did some searches but wasn't able to
find another one.

*** This bug has been marked as a duplicate of 92224 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Yep.

VERIFIED dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.