different line-breaks after br and followin div-tag

VERIFIED DUPLICATE of bug 47793

Status

()

Core
Layout
--
minor
VERIFIED DUPLICATE of bug 47793
17 years ago
17 years ago

People

(Reporter: Jammni, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
Windows ME
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2001072703

Look in the bottom-right frame. You will see the text "Änderungen und 
Neuaufnahmen vom ....". This text appears twice with different dates. But after 
each date follows a br-tag and the green text has it's own div-tag. But after 
the first text there are two new lines and after the second text there is only 
one new line. But it's the same code.

Reproducible: Always
Steps to Reproduce:
1. write some text followed by a br-tag and an div tag
2. copy the text and insert it a second time

Actual Results:  different line-breaks with the same code
This appears to be because you have an open paragraph before the first "br",
producing the extra spacing.  I would suggest checking your page at
<http://validator.w3.org/> to help clear things up.

Comment 2

17 years ago
Created attachment 43917 [details]
Testcase

Comment 3

17 years ago
I don't think the <BR> is important here, you get the same difference without
it. It seems like IE5 and Nav4.7 is doing something odd (collapsing margins?)
when there is a </P> missing.
Severity: normal → minor
Keywords: testcase
(Reporter)

Comment 4

17 years ago
Created attachment 43929 [details]
a new testcase with a surrounding p-tag
We can't and shouldn't depend on whether the end tags were omitted or not.

*** This bug has been marked as a duplicate of 47793 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
You're right David, I had forgot that one. Verifying dup of (WONTFIX) bug 47793.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.