Closed Bug 926936 Opened 6 years ago Closed 6 years ago

Can't launch an app when running Gaia inside Firefox with the desktop helpers

Categories

(Core Graveyard :: DOM: Apps, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla27

People

(Reporter: julienw, Assigned: kgrandon)

Details

(Keywords: regression, Whiteboard: [c= p=1 s= u=])

Attachments

(1 file)

STR:
* have a recent master
* have a desktop profile:
  rm -rf profile-browser && PROFILE_FOLDER=profile-browser DEBUG=1 make profile-browser
* run Firefox nightly with this profile
* try to launch an app

Expected:
* the apps can be launched

Actual:
* nothing happens and there is an error in the console:

System JS : ERROR resource://gre/modules/WebappOSUtils.jsm:224
                     TypeError: aPossiblyBadFilenameString is undefined

Note: on a less recent master, I had the same error for only some apps (tried "dialer" and "contacts") whereas some others worked (tried "messages" and "browser").

Ccing a bunch of people since this could come from either homescreen, Webapps, or the desktop helper.
Most likely need to update some extension code due to bug 924032, I'll take it.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: [c= p= s= u=]
Attachment #817206 - Flags: review?(fabrice)
Comment on attachment 817206 [details]
Github pull request pointer

We also changed 'open-app' and 'close-app'. You want to update those if they are in you shell.js
Attachment #817206 - Flags: review?(fabrice) → feedback+
Comment on attachment 817206 [details]
Github pull request pointer

Hi Fabrice,

We should be ok here. We currently have webapps-launch and open-app - and these have been changed to fire the custom event instead of mozChromeEvent. We're currently not handling close-app at all, but perhaps that could be another bug.
Attachment #817206 - Flags: review?(fabrice)
Attachment #817206 - Flags: review?(fabrice)
Attachment #817206 - Flags: review+
Attachment #817206 - Flags: feedback+
Thanks for the review! If anyone is having this problem, you will need to rebuild your profile after grabbing the latest master.

Landed: https://github.com/mozilla-b2g/gaia/commit/130183cc45b439fde9c5c60c22c077aa5ab8a4e2
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [c= p= s= u=] → [c= p=1 s= u=]
Target Milestone: --- → mozilla27
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.