Closed Bug 926955 (fxos-download-mgr) Opened 7 years ago Closed 2 years ago

[meta] Download Manager

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: arogers, Unassigned)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files, 4 obsolete files)

Meta bug to track all 1.3 Download Manager Features
UX spec for Download Manager is available on Box at: 

https://mozilla.box.com/s/uu6csrbcji3hxldtrmp

The spec includes a MVP proposal on pages 33-38. The MVP for the download manager would retain the Download List, but change the point of entry. 

For the MVP, the Download List is launched automatically when a download is initiated. The Download Manager can also publish notifications when downloads are complete if the Download List is not in the foreground. 

Otherwise, the user can access the Download List from the Settings app. 

The Download List remains the same, expect that it has a “Done” button instead of a “Back”. 

Error handling remains the same.
Attached file DM_settingsDrawerv0.8.pdf (obsolete) —
Attaching the spec in case anyone has issues accessing the file using the link.
Blocks: 929532
Blocks: 929588
Attached file DM_settingsDrawerv0.9.pdf (obsolete) —
Updated DM spec at https://mozilla.box.com/s/6odbxmjvbquihp347yno and attached here
Attached file DM_settingsDrawerv0.10.pdf (obsolete) —
Updated spec attached and also available at: https://mozilla.box.com/s/jf4drimp2k21v45jwuqd
Attached file DownloadManager_v0.11.pdf (obsolete) —
Attaching latest version of the UX spec.
Depends on: 935090
Depends on: 935082
Depends on: 935094
Depends on: 935098
Adding new version of spec - addresses some inconsistencies in the previous version.
Attachment #818655 - Attachment is obsolete: true
Attachment #820657 - Attachment is obsolete: true
Attachment #821714 - Attachment is obsolete: true
Attachment #824384 - Attachment is obsolete: true
Depends on: 936342
Updated to remove the progress bar and stop button from the download-in-progress notification due to technical risk.
Alias: fxos-download-mgr
Depends on: 940290
Depends on: 940294
Depends on: 940298
Depends on: 940432
Depends on: 940966
Updated to address Bug #940886
Whiteboard: [systemsfe]
No longer blocks: 1.3-systems-fe
Depends on: 942424
Why this bug no longer blocks meta bug 923441 of version 1.3? We are working to land it in version 1.3, and as far as I know final decision will be taken on Nov 27th, during Systems FE sprint planning.
Flags: needinfo?(jsmith)
(In reply to Marcelino Veiga Tuimil [:sonmarce] from comment #9)
> Why this bug no longer blocks meta bug 923441 of version 1.3? We are working
> to land it in version 1.3, and as far as I know final decision will be taken
> on Nov 27th, during Systems FE sprint planning.

Let me forward you an email that will explain this.
Flags: needinfo?(jsmith)
Depends on: 945099
Depends on: 944682
Depends on: 945323
Depends on: 945366
Depends on: 945628
Depends on: 945668
Depends on: 946170
Depends on: 946239
Depends on: 946660
Depends on: 946992
Depends on: 947181
Flags: in-moztrap?(rafael.marquez)
Depends on: 947167
No longer depends on: 946992
Depends on: 946543
Per today's Go/No Go discussion, this has been moved out of scope for 1.3. It will be set a committed feature for 1.4.
No longer blocks: 1.3-EPM-Tracking, 1.3-systems-fe
Depends on: 948029
Depends on: 948040
Depends on: 948287
Depends on: 948934
Depends on: 948979
Depends on: 948960
Depends on: 948950
Depends on: 949373
Depends on: 949991
No longer depends on: 948960
Depends on: 941655
Depends on: 936941
Depends on: 935100
Hi Francis, 
I think this download manager should not be included in settings. (Downloads)
It's more like an App. Not a setting for download manager, right?
Flags: needinfo?(fdjabri)
Depends on: 952423
Depends on: 952695
Depends on: 955807
Depends on: 956183
Depends on: 956346
The reason that the Downloads Manager is under settings right now is that it doesn't feel right to me to have it as an application, like Android does. The functionality we currently have in place is too minimal to be an app. The Download Manager should be part of the system, and not an app. The eventual plan to allow the user to link to the DM via the Settings tray - until then, the user can access it via notifications and settings.
Flags: needinfo?(fdjabri)
Depends on: 957592
Depends on: 957605
No longer depends on: 949368
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
Duplicate of this bug: 957799
Depends on: 957971
Depends on: 958051
No longer depends on: 958051
Depends on: 959211
No longer depends on: 946170
Depends on: 959340
No longer depends on: 956346
Depends on: 961358
No longer depends on: 956183
Depends on: 960749
Target Milestone: 1.3 C2/1.4 S2(17jan) → 1.3 C3/1.4 S3(31jan)
No longer depends on: 924586
Target Milestone: 1.3 C3/1.4 S3(31jan) → 1.4 S1 (14feb)
Target Milestone: 1.4 S1 (14feb) → ---
No longer blocks: 929588
No longer depends on: 948960
Depends on: 970225
Depends on: 970255
Depends on: 970267
Depends on: 970303
Depends on: 970340
Depends on: 970818
No longer depends on: 955807
Depends on: 966141
Depends on: 973404
No longer depends on: 948950
Duplicate of this bug: 976712
Depends on: 949451
Depends on: 961014
Depends on: 977094
Depends on: 977100
Depends on: 977627
No longer depends on: 977100
Depends on: 979446
Depends on: 979795
Depends on: 981657
Depends on: 981938
Depends on: 982006
Depends on: 982295
No longer depends on: 976011
Depends on: 1000454
Depends on: 1005384
Depends on: 1005390
Depends on: 1007965
Depends on: 1012845
Depends on: 1015489
Depends on: 1015522
Depends on: 1016463
No longer depends on: 1015489
No longer depends on: 1016463
No longer depends on: 1016463
No longer depends on: 1017509
Depends on: 1017509
Depends on: 1017533
No longer depends on: 1017533
Depends on: 1022804
Depends on: 1026252
No longer depends on: 1025853
Depends on: 1034500
Depends on: 1020103
Depends on: 1035367
Depends on: 1037334
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.