Closed Bug 926956 Opened 8 years ago Closed 8 years ago

Flash content not working when Plugins are set to "Tap to play"

Categories

(Firefox for Android Graveyard :: General, defect)

27 Branch
All
Android
defect
Not set
normal

Tracking

(firefox26 unaffected, firefox27 verified, fennec27+)

RESOLVED DUPLICATE of bug 920927
Tracking Status
firefox26 --- unaffected
firefox27 --- verified
fennec 27+ ---

People

(Reporter: u421692, Assigned: gfritzsche)

Details

(Keywords: regression)

Attachments

(1 file)

Attached file flash_taptoplay
Environment:
Device: Samsung Galaxy Nexus (Android 4.1.1) / HTC Desire HD (Android 2.3.5)
Build: Nightly 27.0a1 (2013-10-15)

Steps to reproduce:
1. Open Firefox and go to Settings->Display->Plugins and choose "Tap to play"
2. Open a site playing flash content (e.g.: www.intel.com/museumofme/‎ or Youtube Desktop Site)

Expected result:
The flash content is played after tapping on the flash placeholder

Actual result:
The flash placeholder is not displayed, and you can not play the flash player by tapping on the place where the flash placeholder should be.

Note: There are some JavaScript errors in logcat, attaching the logs.
Let's see if we can get a regression range.

Georg, are you the right person to ask about problems with click-to-play plugins? I worked on the original Fennec implementation, but I haven't been following new click-to-play work closely, so I'm not sure if some platform code might have caused this regression.
Flags: needinfo?(georg.fritzsche)
The placeholder not being visible was probably my breakage from not considering Fennec in bug 790483 and should be fixed by bug 920927 in the next Nightly.

I'm currently following up on the major click-to-play issues for bug 899080 et al, although i just started looking into Fennec for bug 920927. bsmedberg, keeler and jaws should also be good for CtP questions.
Flags: needinfo?(georg.fritzsche)
tracking-fennec: --- → ?
Pop - Can you get a regression range
Assignee: nobody → georg.fritzsche
tracking-fennec: ? → 27+
Flags: needinfo?(mihai.g.pop)
Bug 920927 landed on m-c yesterday, so i'd expect this to be fixed in the latest Nightly.
Verified as fixed on:
Device: Samsung Galaxy Nexus (Android 4.1.1) / Asus Transformer TF101 (Android 4.0.3)
Build: Nightly 27.0a1 (2013-10-17)
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(mihai.g.pop)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Status: VERIFIED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 920927
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.