url autofillin does not match dropdown menu

RESOLVED DUPLICATE of bug 995091

Status

()

Firefox
Location Bar
--
enhancement
RESOLVED DUPLICATE of bug 995091
4 years ago
3 years ago

People

(Reporter: ill, Unassigned)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911155223

Steps to reproduce:

when typing in the url bar, the autocomplete will not choose what website to autofill in based on how much it was previously visited, nor does it correspond to the drop down menu, it seems to just choose what to fill in randomly.


Actual results:

see above


Expected results:

It should be in line with the drop down menu, or at least have an option to disable it if it's not going to be fixed.

Updated

4 years ago
Severity: normal → enhancement

Updated

4 years ago
Component: Untriaged → Location Bar
I think this is a support question not a bug. This article may help you understand the location bar autocomplete behavior and how to improve the autocomplete results so that they're closer to what you want:

https://support.mozilla.org/en-US/kb/awesome-bar-find-your-bookmarks-history-and-tabs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
It is inconsistent to have awesomebar sort itself by history usage, but not have the url autocomplete do the same. There is no reason that url autocomplete can't do the same usage sorting.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
the autofill does sort by history usage, it's just that it doesn't show the entry in the popup, that was done by design to increase the possible choices and avoid breaking some old behavior.
Actually we are changing the behavior in bug 995091 so it may be different in future versions.
there is already an option to disable autofill, that is browser.urlbar.autoFill in about:config
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 995091
You need to log in before you can comment on or make changes to this bug.