Lightning: Cannot dismiss event reminders

RESOLVED DUPLICATE of bug 356002

Status

Calendar
General
RESOLVED DUPLICATE of bug 356002
4 years ago
4 years ago

People

(Reporter: Jessilyn Davis (Maternity Leave), Unassigned)

Tracking

Lightning 2.6
x86
Mac OS X

Details

(Reporter)

Description

4 years ago
Tbird version: 24.0.1

Lightning version: 2.6

I cannot successfully dismiss, discard and reload, nor submit my changes anyway to a calendar reminder. It just keeps popping up after I hit any of those button options. 


Errors:
Timestamp: 10/15/13 10:59:50 AM
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: resource://calendar/modules/calXMLUtils.jsm
Line: 32


[JavaScript Error: "[Exception... "'[JavaScript Error: "foundAttendee is null" {file: "resource://calendar/modules/calItipUtils.jsm" line: 1209}]' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///Users/jdavis/Library/Thunderbird/Profiles/xqsadmj6.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js :: calCompositeGetListenerHelper.prototype.onOperationComplete :: line 520"  data: yes]"]

Comment 1

4 years ago
Do you have write access to the calendar that contains the events want to modify?

Does the error message is reported when pressing the buttons in the reminder dialog? 
The message seem related to handling of email based event invitations and not reminders.
Component: General → General
Product: Thunderbird → Calendar
Version: 24 → Lightning 2.6
(Reporter)

Comment 2

4 years ago
(In reply to Stefan Sitter from comment #1)
> Do you have write access to the calendar that contains the events want to
> modify?

I do not.

> 
> Does the error message is reported when pressing the buttons in the reminder
> dialog? 

Correct. The error happens when I try to press the "dismiss" button in the reminder pop-up - both "dismiss all" or "dismiss" the individual alert. I finally got the error to stop when I went to my calendar via zimbra, deleted it there, and then synced by calendar in Thunderbird.

> The message seem related to handling of email based event invitations and
> not reminders.
Definitely could be for sure.

Comment 3

4 years ago
This explains it. You cannot modify events or reminders in a read-only calendar -> same as Bug 356002. Do you agree?
Flags: needinfo?(jdavis)
(Reporter)

Comment 4

4 years ago
Ah - I think you're right. If I run into this error again and its' not with a read-only calendar/event, I'll reopen.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jdavis)
Resolution: --- → DUPLICATE
Duplicate of bug: 356002
You need to log in before you can comment on or make changes to this bug.