If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent test_bookmarks_html.js | test failed (with xpcshell return code: 0), see following log | promise.js | Unexpected exception TypeError: data.livemark.siteURI is null, see following stack

RESOLVED DUPLICATE of bug 748573

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 748573
4 years ago
4 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86_64
Mac OS X
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=29144172&tree=Mozilla-Beta
using slave: talos-r4-snow-062



10:58:01     INFO -  TEST-INFO | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmark_catobs.js | running test ...
10:58:02     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmark_catobs.js | test passed (time: 1393.162ms)
10:58:02     INFO -  TEST-INFO | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_json.js | running test ...
10:58:03     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_json.js | test passed (time: 735.536ms)
10:58:03     INFO -  TEST-INFO | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | running test ...
10:58:04  WARNING -  TEST-UNEXPECTED-FAIL | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | test failed (with xpcshell return code: 0), see following log:
10:58:04     INFO -  >>>>>>>
10:58:04     INFO -  TEST-INFO | (xpcshell/head.js) | test MAIN run_test pending (1)
10:58:04     INFO -  TEST-INFO | (xpcshell/head.js) | test run_next_test 0 pending (2)
10:58:04     INFO -  TEST-INFO | (xpcshell/head.js) | test MAIN run_test finished (2)
10:58:04     INFO -  TEST-INFO | (xpcshell/head.js) | running event loop
10:58:04     INFO -  TEST-INFO | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | Starting setup
10:58:04     INFO -  TEST-INFO | (xpcshell/head.js) | test setup pending (2)
10:58:04     INFO -  TEST-INFO | (xpcshell/head.js) | test run_next_test 0 finished (2)
10:58:04     INFO -  TEST-INFO | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | "[testImportedBookmarks()] Checking group 'menu'"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [testImportedBookmarks : 266] 3 == 3
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "Mozilla Firefox" == "Mozilla Firefox"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 389] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 391] 4 == 4
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "Help and Tutorials" == "Help and Tutorials"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "Customize Firefox" == "Customize Firefox"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "Get Involved" == "Get Involved"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "About Us" == "About Us"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 314] 7 == 7
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "test" == "test"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 322] "folder test comment" == "folder test comment"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 326] 1177541020000000 == 1177541020000000
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 330] 1177541050000000 == 1177541050000000
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 389] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 391] 1 == 1
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "test post keyword" == "test post keyword"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 322] "item description" == "item description"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 326] 1177375336000000 == 1177375336000000
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 330] 1177375423000000 == 1177375423000000
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 363] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 368] "hidden1%3Dbar&text1%3D%25s" == "hidden1%3Dbar&text1%3D%25s"
10:58:04     INFO -  TEST-INFO | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | "[testImportedBookmarks()] Checking group 'toolbar'"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [testImportedBookmarks : 266] 2 == 2
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "Getting Started" == "Getting Started"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 372] "ISO-8859-1" == "ISO-8859-1"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 355] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 355] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 355] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 355] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 355] true == true
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 317] "Latest Headlines" == "Latest Headlines"
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js | [checkItem/< : 382] true == true
10:58:04  WARNING -  TEST-UNEXPECTED-FAIL | resource://gre/modules/commonjs/sdk/core/promise.js | Unexpected exception TypeError: data.livemark.siteURI is null, see following stack:
10:58:04     INFO -  checkItem/<@/builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js:383
10:58:04     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:192
10:58:04     INFO -  resolve@resource://gre/modules/commonjs/sdk/core/promise.js:122
10:58:04     INFO -  then@resource://gre/modules/commonjs/sdk/core/promise.js:47
10:58:04     INFO -  resolve@resource://gre/modules/commonjs/sdk/core/promise.js:189
10:58:04     INFO -  checkItem/</<@/builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js:379
10:58:04     INFO -  LS_getLivemark_ETAT@resource://gre/components/nsLivemarkService.js:358
10:58:04     INFO -  TEST-INFO | (xpcshell/head.js) | exiting test
10:58:04     INFO -  <<<<<<<
10:58:04     INFO -  TEST-INFO | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html_corrupt.js | running test ...
10:58:04     INFO -  TEST-PASS | /builds/slave/talos-slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html_corrupt.js | test passed (time: 532.766ms)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748573
You need to log in before you can comment on or make changes to this bug.