Hide collections with no apps from the consumer pages

VERIFIED FIXED in 2013-10-21

Status

Marketplace
Consumer Pages
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Assigned: spasovski)

Tracking

({regression})

2013-10-21
regression
Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
If the collections has no app in it, then we shouldn't display it in the consumer pages. Example: https://marketplace.firefox.com/collection/movistar-pe

Code @ https://github.com/mozilla/fireplace/blob/master/hearth/templates/category/main.html#L51 says this should work ==> regression.
Davor's taken care of this in a patch for another bug - woo!
Assignee: nobody → dspasovski
Depends on: 923236
Target Milestone: --- → 2013-10-21
https://github.com/mozilla/fireplace/commit/cb08301

Thanks, Davor!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 years ago
We still list blank featured apps collections on the homepage. See https://marketplace-dev.allizom.org/category/all/featured?src=category-featured
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://github.com/mozilla/fireplace/commit/8fc1cb8
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 5

4 years ago
This is still reproducible on Stage : http://screencast.com/t/OTXO1cMMi
I was not able to test on -dev because of https://bugzilla.mozilla.org/show_bug.cgi?id=928353
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 928445
(Assignee)

Comment 7

4 years ago
this should address it: https://github.com/mozilla/fireplace/commit/de11eed
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 8

4 years ago
We have a strange issue now. The bug https://bugzilla.mozilla.org/show_bug.cgi?id=928353 is now reproducible only for Stage, even if initially it was logged only for -dev(On -dev the issue was solved meanwhile)

In conclusion, no collections are displayed on Stage even if they are not empty(see https://marketplace.allizom.org/curation/collection/dasdas)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

4 years ago
Victor: What you seem to be seeing is that the collection is hidden because of device type/buchet filtering. We don't hide the collection because it's "empty", we hide it because there are no apps in a collection to show to the user. That means that if apps are filtered out and the collection is empty because of that, we will hide the collection.

If you're still not seeing collections and you're certain that they're not being filtered, please file a new bug.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

4 years ago
verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.