Closed Bug 927128 Opened 6 years ago Closed 6 years ago

Keep GeckoView limited to Nightly only

Categories

(Core Graveyard :: Embedding: GRE Core, defect)

x86_64
Linux
defect
Not set

Tracking

(firefox26 unaffected, firefox27+ fixed, firefox28 fixed, firefox29 fixed)

RESOLVED FIXED
mozilla29
Tracking Status
firefox26 --- unaffected
firefox27 + fixed
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

(Whiteboard: [qa-])

Attachments

(2 files)

We don't want GeckoView to move out of Nightly until we get the APIs a bit more mature
Mike - I think this should be enough to stop GeckoView from getting built anywhere but Nightly
Assignee: nobody → mark.finkle
Attachment #8343546 - Flags: review?(mh+mozilla)
Comment on attachment 8343546 [details] [diff] [review]
nightly-only v0.1

Review of attachment 8343546 [details] [diff] [review]:
-----------------------------------------------------------------

That'd prevent people from building a geckoview on non nightly branches if they want to. I don't know if it's a problem or not. If it is, it would be better to to that at configure.in level, resetting MOZ_DISABLE_GECKOVIEW when it's not already set (as in, export MOZ_DISABLE_GECKOVIEW=). That can be checked with:
  test "${MOZ_DISABLE_GECKOVIEW-unset}" = unset.
Attachment #8343546 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/integration/fx-team/rev/e7a6c931bcf5

But I do want to make a nicer approach, like the one in comment 2. I need this on Fx27 so I'll land this one for now.
Whiteboard: [leave-open]
Comment on attachment 8343546 [details] [diff] [review]
nightly-only v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): GeckoView
User impact if declined: GeckoView widget is not ready for release, so we want to limit it to Nightly for now
Testing completed (on m-c, etc.): just landed
Risk to taking this patch (and alternatives if risky): simple makefile flag
String or IDL/UUID changes made by this patch: none
Attachment #8343546 - Flags: approval-mozilla-aurora?
Comment on attachment 8343546 [details] [diff] [review]
nightly-only v0.1

PLease set the status-firefox27 -> disabled , once landed.
Attachment #8343546 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I forgot to add the stub for INNER_MAKE_GECKOVIEW_LIBRARY. Without it, we break here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/packager.mk#462
Attachment #8344121 - Flags: review?(mh+mozilla)
Backed out from Aurora due to the same bustage that hit when this was uplifted during the last cycle. We can land this on Aurora/Beta once the bustage fix gets reviewed.

https://hg.mozilla.org/releases/mozilla-aurora/rev/ecb386453084
Whiteboard: [leave-open]
Attachment #8344121 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8343546 [details] [diff] [review]
nightly-only v0.1

Batch request for both patches

[Approval Request Comment]
Bug caused by (feature/regressing bug #): GeckoView libraries
User impact if declined: Shipping alpha-ready GeckoView. We do not want the GeckoView libraries to move past Nightly yet.
Testing completed (on m-c, etc.): bustage fix now landed
Risk to taking this patch (and alternatives if risky): Should not affect Fennec/Firefox, but can break the build. The bustage fix corrects that.
String or IDL/UUID changes made by this patch: None
Attachment #8343546 - Flags: approval-mozilla-beta?
Attachment #8343546 - Flags: approval-mozilla-aurora?
Attachment #8343546 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/bc93b00a405b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Attachment #8343546 - Flags: approval-mozilla-beta?
Attachment #8343546 - Flags: approval-mozilla-beta+
Attachment #8343546 - Flags: approval-mozilla-aurora?
Attachment #8343546 - Flags: approval-mozilla-aurora+
Whiteboard: [qa-]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.