e10s: "chrome://browser/content/content.js: TypeError: Services.search is undefined" when reloading about:home

RESOLVED FIXED in Firefox 27

Status

()

Firefox
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: cpeterson, Assigned: billm)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 27
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR:
1. Run a debug build with e10s enabled from the command line
2. Load about:home
3. Watch stderr
4. Reload about:home

RESULT:
System JS : ERROR chrome://browser/content/content.js:91
                     TypeError: Services.search is undefined
This looks like a regression from bug 900865.
Blocks: 900865
How so? Does the global-sharing for content scripts work differently in e10s builds?
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #2)
> How so? Does the global-sharing for content scripts work differently in e10s
> builds?

I'm not sure why the access is considered an error. That might be worth investigating, since we use Services elsewhere in that file.

The problem I was worried about is that Services.search.defaultEngine will (I assume) only be correct in the parent process, so we should be sending its value in a message from the parent.

I'll try to look at this more closely next week.
Oh, I see - the search service initialization in the child must be failing for some reason.
Created attachment 821368 [details] [diff] [review]
fix-about-home

I just passed the search engine name down from the parent.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #821368 - Flags: review?(mdeboer)
Duplicate of this bug: 927137
Comment on attachment 821368 [details] [diff] [review]
fix-about-home

Review of attachment 821368 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks for working on this!
Attachment #821368 - Flags: review?(mdeboer) → review+
I filed bug 930456 to cover the general problem of the search service not working in child processes.
https://hg.mozilla.org/mozilla-central/rev/c6a4d3416d87
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.