If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crashes in IOAccelerator | libGPUSupportMercury.dylib@0x23fe on OS X 10.8

RESOLVED WONTFIX

Status

()

Core
Graphics
--
critical
RESOLVED WONTFIX
4 years ago
a year ago

People

(Reporter: smichaud, Assigned: milan)

Tracking

({crash, steps-wanted})

Trunk
All
Mac OS X
crash, steps-wanted
Points:
---

Firefox Tracking Flags

(firefox24 wontfix, firefox25 wontfix, firefox26 wontfix, firefox27 wontfix, firefox28 wontfix, firefox29 wontfix)

Details

(crash signature)

These crashes go back a long way, in small numbers.  But their frequency increased substantially with the FF 24 release, and their relative frequency has continued to increase.

These are the #21 Mac topcrasher over the last week in FF 24.  But they're #10 on the 26 branch and #9 on the 27 branch.
(Reporter)

Updated

4 years ago
Crash Signature: [@ IOAccelerator@0x1997 ] [@ IOAccelerator@0x24f2 ]
(Reporter)

Comment 1

4 years ago
Up through FF 24, these happen mostly (always?) on the main thread.  But on the 25 branch and up they happen mostly (always?) on secondary threads.
(Reporter)

Updated

4 years ago
tracking-firefox26: --- → ?
tracking-firefox27: --- → ?
(Reporter)

Comment 2

4 years ago
https://crash-stats.mozilla.com/report/list?signature=IOAccelerator%400x1997&product=Firefox&query_type=contains&range_unit=weeks&process_type=any&platform=mac&hang_type=any&date=2013-10-15+23%3A00%3A00&range_value=4#reports
(Reporter)

Comment 3

4 years ago
Some of the comments refer to video or audio.

Here are some URLs I gleaned from them:

http://www.japanesepod101.com/
http://stackoverflow.com/
http://www.theweathernetwork.com/
(Reporter)

Updated

4 years ago
Severity: normal → critical

Updated

4 years ago
status-firefox24: --- → wontfix
status-firefox25: --- → wontfix
tracking-firefox26: ? → +
tracking-firefox27: ? → +
Keywords: qawanted, steps-wanted, topcrash-mac
(In reply to Steven Michaud from comment #3)
> http://www.japanesepod101.com/
> http://stackoverflow.com/
> http://www.theweathernetwork.com/
I couldn't reproduce any crash on FF 27.0a1 (2013-10-28) Mac OS X 10.8.4 with the above URLs.
Keywords: qawanted
QA Contact: paul.silaghi
Too late now for the FF26 timeframe.
status-firefox26: --- → wontfix
We need an assignee here if this is going to get the attention it deserves. If it's increasing in quantity on Mac since FF24 perhaps someone can take a moment to look at changes to this area of code for starters?
Assignee: nobody → milan
status-firefox27: --- → affected
status-firefox28: --- → affected
status-firefox29: --- → affected
tracking-firefox28: --- → +
tracking-firefox29: --- → +
Flags: needinfo?(milan)
(Reporter)

Comment 7

4 years ago
These have fallen off substantially recently.  I suspect it's because the number of FF users on OS X 10.8 has fallen dramatically since Mavericks (OS X 10.9) was released.  So this is/was probably an OS bug.

The aren't even among the top 100 crashers on the 28 and 27 branches, and are #93 on the 26 branch.

(Interestingly we still have large numbers of users on OS X 10.6 (Snow Leopard) and 10.7 (Lion).  This is probably because 10.9 is an automatic update for 10.8, but not for 10.6 or 10.7.  You have to explicitly get 10.9 from the App Store for 10.6 and 10.7.)
Keywords: topcrash-mac
(Reporter)

Comment 8

4 years ago
> the number of FF users on OS X 10.8 has fallen dramatically since
> Mavericks (OS X 10.9) was released

Just to make it clear, there's been an equally dramatic and equally
large increase in the number of FF users on OS X 10.9.
(Reporter)

Comment 9

4 years ago
> These have fallen off substantially recently

So we should probably stop tracking them.
(Assignee)

Comment 10

4 years ago
Let me know - if we're still tracking, I'll find somebody.
Flags: needinfo?(milan)
Since it's no longer a topcrash we won't track this as a release blocker.
tracking-firefox28: + → -
tracking-firefox29: + → -

Updated

4 years ago
tracking-firefox27: + → -
This still affects current branches on Mac OS 10.8 in extremely low volume. I'm closing this as INCOMPLETE since we've made no progress on this bug in over a year. Please reopen if there are any new leads.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox27: affected → wontfix
status-firefox28: affected → wontfix
status-firefox29: affected → wontfix
tracking-firefox26: + → ---
tracking-firefox27: - → ---
tracking-firefox28: - → ---
tracking-firefox29: - → ---
Keywords: crash
Resolution: --- → INCOMPLETE
(Assignee)

Comment 13

2 years ago
Let's leave it open.  It's a crash, it's still showing up.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(In reply to Milan Sreckovic [:milan] from comment #13)
> Let's leave it open.  It's a crash, it's still showing up.

I'm not sure there's a point in leaving this bug open any longer. On average we're seeing this 3 times a day with 3 unique install timestamps. Even on Mac that's an extremely thin margin of users. Add to that the fact that this happens *only* on Mac OS 10.8, a platform we plan to deprecate very soon.

I just don't see a point in keeping this open unless we're going to fix this in time to uplift to the last Firefox version to support 10.8.
This is still being reported ~2 times a day on average.
Status: REOPENED → NEW
I am closing this bug as WONTFIX since Firefox 48, released last week, is the last version to support MacOS 10.8 and this crash does not occur on MacOS 10.9+.
Status: NEW → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.