Closed Bug 927186 Opened 8 years ago Closed 8 years ago

Regression: Default globe favicon does not always appear when no favicon available

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec27+)

RESOLVED DUPLICATE of bug 938153
Tracking Status
fennec 27+ ---

People

(Reporter: aaronmt, Assigned: bnicholson)

References

Details

(Keywords: regression)

Attachments

(1 file)

Currently on occasion I do not see the default globe favicon appear when no favicon is available. See screenshot. No steps in particular, just load a site without a favicon, on occasion you will see an empty spot, even with a complete page loaded.

--
Nightly (10/15) | Samsung Galaxy SIV (Android 4.3)
Keywords: regression
This might be a regression from Bug 923218 that we didn't notice.

Is this reproducible with the patch from Bug 923218 but not the one from Bug 914296? I imagine this is a sort of difficult question to answer if things are intermittent like you say.

Does this ever happen in the lists in the new about:home, or is it exclusively up in the tab bar?
Keywords: regression
tracking-fennec: ? → 27+
Keywords: regression
Regression window-wanted:
mc:
not affected build: 13-10-2013
affected build: 14-10-2013  
-pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a50141faaab9&tochange=211337f7fb83
Seems to be a regression from bug 914296.
Sorry, yes, it might well be a regression from bug 923218.
Seems 100% reproducible when just opening something that spawns another intent

I/ActivityManager(  522): START u0 {act=android.intent.action.VIEW dat=http://qthttp.apple.com.edgesuite.net/1010qwoeiuryfg/0150_vod.m3u8 flg=0x10000000 cmp=org.mozilla.fennec/.App} from pid 18652

Open http://qthttp.apple.com.edgesuite.net/1010qwoeiuryfg/0150_vod.m3u8 in Fennec and you'll see no default globe for that .m3u8 file.
Assignee: nobody → bnicholson
Keywords: qawanted
On 29.0/28.0/27.0 -> comment #5 -> frozen throbber

I don't have steps to reproduce on actual site; it happened when I filed. If we understand what the above is and if it's different we can mark this as WFM and re-open if the original issue happens again.

As for comment #5 at the time I was getting a blank spot, I seem to spot a frozen non-moving throbber now when I load the .m3u8 URL I posted.
Status: NEW → ASSIGNED
Keywords: qawanted
I don't see this bug anymore. This sounds like a lot like bug 938153, which was fixed, so I think this is a dupe.

That said, I am seeing a frozen throbber as Aaron mentioned in comment 6. It's possible that we simply replaced one bug another, but in any case, the previously reported symptoms of an empty favicon seem to be gone.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938153
(In reply to Brian Nicholson (:bnicholson) from comment #7)

> That said, I am seeing a frozen throbber as Aaron mentioned in comment 6.

Nightly has a busted throbber today. See bug 956705. Should be fixed tomorrow.
(In reply to Mark Finkle (:mfinkle) from comment #8)
> Nightly has a busted throbber today. See bug 956705. Should be fixed
> tomorrow.

Different issue
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.