e10s: Flash content crashes chrome process in MacIOSurfaceLib::IOSurfaceGetWidth()

RESOLVED DUPLICATE of bug 923746

Status

()

--
critical
RESOLVED DUPLICATE of bug 923746
5 years ago
5 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

5 years ago
STR:
1. Try to load a simple Flash website, like zombo.com

RESULT:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: 13 at address: 0x0000000000000000
[Switching to process 60246 thread 0x8c13]
0x00007fff81e9b932 in IOSurfaceGetWidth ()
(gdb) bt
#0  0x00007fff81e9b932 in IOSurfaceGetWidth ()
#1  0x000000010399eb64 in MacIOSurfaceLib::IOSurfaceGetWidth () at mozilla/gfx/2d/QuartzSupport.mm:182
#2  0x000000010399eb64 in MacIOSurface::GetDevicePixelWidth () at mozilla/objdir-mac/dist/include/mozilla/gfx/MacIOSurface.h:395
#3  0x000000010399eb64 in MacIOSurface::CGLTexImageIOSurface2D (this=0x115ad4fc0, c=<value temporarily unavailable, due to optimizations>) at mozilla/gfx/2d/QuartzSupport.mm:453
#4  0x0000000103423023 in mozilla::gl::GLContextCGL::AttachSharedHandle (this=<value temporarily unavailable, due to optimizations>, shareType=<value temporarily unavailable, due to optimizations>, sharedHandle=2451669042180718592) at mozilla/gfx/gl/GLContextProviderCGL.mm:226
#5  0x00000001033e763b in mozilla::layers::SharedTextureSourceOGL::BindTexture (this=0x10ba031f0, aTextureUnit=<value temporarily unavailable, due to optimizations>) at mozilla/gfx/layers/opengl/TextureHostOGL.cpp:312
#6  0x00000001033923a2 in mozilla::layers::CompositorOGL::DrawQuad (this=0x10fdb5eb0, aRect=@0x11e9e5b80, aClipRect=<value temporarily unavailable, due to optimizations>, aEffectChain=<value temporarily unavailable, due to optimizations>, aOpacity=1, aTransform=@0x10ba03210, aOffset=@0x10ba031f0) at mozilla/gfx/layers/opengl/CompositorOGL.cpp:977
#7  0x00000001033b7236 in mozilla::layers::CompositableHost::GetCompositor () at mozilla/gfx/layers/composite/CompositableHost.h:146
#8  0x00000001033b7236 in mozilla::layers::ImageHost::Composite (this=0x1103266e0, aEffectChain=@0x10c780140, aOpacity=1, aTransform=@0x10c7800f8, aOffset=@0x10c7800e0, aFilter=<value temporarily unavailable, due to optimizations>, aClipRect=@0x10c7800e8, aVisibleRegion=0x0, aLayerProperties=0x0) at mozilla/gfx/layers/composite/ImageHost.cpp:148
#9  0x00000001033b857c in mozilla::layers::ImageLayerComposite::RenderLayer (this=<value temporarily unavailable, due to optimizations>, aOffset=<value temporarily unavailable, due to optimizations>, aClipRect=<value temporarily unavailable, due to optimizations>) at mozilla/gfx/layers/composite/ImageLayerComposite.cpp:108
#10 0x000000010339d52a in mozilla::layers::ContainerRender<mozilla::layers::ContainerLayerComposite> (aContainer=0x1103e7400, aOffset=@0x10c780678, aManager=0x117d34a10, aClipRect=@0x10c780558) at mozilla/gfx/layers/composite/ContainerLayerComposite.cpp:201
#11 0x000000010339e41a in mozilla::layers::ContainerRender<mozilla::layers::RefLayerComposite> (aContainer=0x1441a8c00, aOffset=@0x10c780928, aManager=0x117d34a10, aClipRect=@0x10c780808) at mozilla/gfx/layers/composite/ContainerLayerComposite.cpp:201
#12 0x000000010339d52a in mozilla::layers::ContainerRender<mozilla::layers::ContainerLayerComposite> (aContainer=0x10ebc0c00, aOffset=@0x10c7809a8, aManager=0x117d34a10, aClipRect=@0x10c780a00) at mozilla/gfx/layers/composite/ContainerLayerComposite.cpp:201
#13 0x00000001033bda64 in mozilla::RefPtr<mozilla::layers::Compositor>::operator-> () at mozilla/objdir-mac/dist/include/mozilla/RefPtr.h:359
#14 0x00000001033bda64 in mozilla::layers::LayerManagerComposite::Render (this=0x117d34a10) at mozilla/gfx/layers/composite/LayerManagerComposite.cpp:362
#15 0x00000001033bd5f9 in mozilla::layers::LayerManagerComposite::EndTransaction (this=0x117d34a10, aCallback=0, aCallbackData=0x0, aFlags=<value temporarily unavailable, due to optimizations>) at mozilla/gfx/layers/composite/LayerManagerComposite.cpp:211
#16 0x00000001033bd4de in mozilla::layers::LayerManagerComposite::EndEmptyTransaction (this=0x10fdb5eb0, aFlags=<value temporarily unavailable, due to optimizations>) at mozilla/gfx/layers/composite/LayerManagerComposite.cpp:176
#17 0x000000010339930a in profiler_tracing () at mozilla/objdir-mac/dist/include/GeckoProfilerImpl.h:542
#18 0x000000010339930a in mozilla::layers::CompositorParent::Composite (this=<value temporarily unavailable, due to optimizations>) at mozilla/gfx/layers/ipc/CompositorParent.cpp:550
#19 0x00000001032f27c9 in MessageLoop::RunTask () at mozilla/ipc/chromium/src/base/message_loop.h:338
#20 0x00000001032f27c9 in MessageLoop::DeferOrRunPendingTask (this=0x10c780d00, pending_task=<value temporarily unavailable, due to optimizations>) at mozilla/ipc/chromium/src/base/message_loop.cc:346
#21 0x00000001032f2ada in MessageLoop::DoWork (this=0x10c780d00) at mozilla/ipc/chromium/src/base/message_loop.cc:446
#22 0x00000001032f54c9 in base::MessagePumpDefault::Run (this=0x10c186a40, delegate=0x10c780d00) at mozilla/ipc/chromium/src/base/message_pump_default.cc:24
#23 0x00000001032f20f6 in MessageLoop::AutoRunState::~AutoRunState () at mozilla/ipc/chromium/src/base/message_loop.cc:220
#24 0x00000001032f20f6 in MessageLoop::AutoRunState::~AutoRunState () at mozilla/ipc/chromium/src/base/message_loop.h:188
#25 0x00000001032f20f6 in MessageLoop::Run (this=0x10c780d00) at mozilla/ipc/chromium/src/base/message_loop.cc:506
#26 0x00000001032f91dd in base::Thread::ThreadMain (this=0x10fdb95e0) at mozilla/ipc/chromium/src/base/thread.cc:160
#27 0x00000001032fcaea in ThreadFunc (closure=0x10fdb5eb0) at mozilla/ipc/chromium/src/base/platform_thread_posix.cc:39
#28 0x00007fff81829772 in _pthread_start ()
#29 0x00007fff818161a1 in thread_start ()
See also bug 923746, OS X plugins are semi-windowless, but use some native widgets similar to windowed-mode plugins
(Reporter)

Updated

5 years ago
tracking-e10s: --- → +
John, is this a dupe of bug 923746?
Flags: needinfo?(jschoenick)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> John, is this a dupe of bug 923746?

Most likely. IIRC OS X always uses some manner of native widget code even in "windowless" mode, so flash is not expected to work without windowed support.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jschoenick)
Resolution: --- → DUPLICATE
Duplicate of bug: 923746
You need to log in before you can comment on or make changes to this bug.