Australis: Some addons' removed toolbar buttons reappear after opening a new window

RESOLVED DUPLICATE of bug 940099

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 940099
4 years ago
4 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox28 affected)

Details

(Reporter)

Description

4 years ago
STR:
1. Using Australis, install Mozilla's "Collusion" addon [1] and Gareth Hunt's "Modify Headers" addon [2]
2. These addons add some annoying toolbar buttons to the Australis navbar.
3. Customize the navbar.
4. Remove these addons' buttons.
5. Close the customization tab.
6. Open a new window (using CMD+N or "File > New Window" menu)

RESULT:
The Collusion and Modify Header toolbar buttons are back!

I have other addons installed, but only these two seem to restore their toolbar buttons.

[1] https://www.mozilla.org/en-US/collusion/
[2] https://addons.mozilla.org/en-US/firefox/addon/modify-headers/
(Reporter)

Updated

4 years ago
status-firefox28: --- → affected

Comment 1

4 years ago
Modify Headers does this itself:

https://mxr.mozilla.org/addons/source/967/chrome/content/toolsOverlay.xul#50

It'd need to be updated to stop it being so annoying.

Collusion is an SDK add-on, we'll likely need to look at the SDK and/or if people are just misusing an SDK library. See bug 940099.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940099
You need to log in before you can comment on or make changes to this bug.