Mark as deleted multiple IMAP msgs moves highlight to last message in folder

VERIFIED DUPLICATE of bug 89394

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED DUPLICATE of bug 89394
17 years ago
14 years ago

People

(Reporter: Lorenzo Colitti, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

If you set deletion mode to "Mark it as deleted" and delete multiple messages
from an IMAP folder, the messages are deleted properly but the highlight moves
to the last message in the folder. This is irritating.

Reproducible: Always
Steps to Reproduce:
1. Set IMAP message delete mode to "Mark it as deleted"
2. Open an IMAP folder and select two or more messages
3. Delete the messages (e.g. with Edit->Delete selected messages)

Actual Results:  The messages are marked as deleted but the current message is
now the last message in the folder.

Expected Results:  The highlight should move to the message before the first
message deleted or some other reasonable place.
Try a nightly build, I think this may have been fixed recently.

Updated

17 years ago
QA Contact: esther → huang

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 89394 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.