Last Comment Bug 927315 - Upgrade Vlado Valastiak LDAP account to be able to commit to hg as a localizer
: Upgrade Vlado Valastiak LDAP account to be able to commit to hg as a localizer
Status: VERIFIED FIXED
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Rick Bryce [:rbryce]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 02:01 PDT by Pascal Chevrel:pascalc(PTO until Sept 2)
Modified: 2013-10-16 14:11 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Pascal Chevrel:pascalc(PTO until Sept 2) 2013-10-16 02:01:35 PDT
Vlado (valastiak@mozilla.sk) already has access to svn as our web localizer for mozilla.org (bug 435654), it would be good to also have him as a backup person for products on hg, especially since he is alredy familiar with mercurial.

Vlado, can you attach your ssh public key to this bug? Axel, can you precise which exact rights need to be added to his LDAP account?

Thanks
Comment 1 Axel Hecht [pto-Aug-30][:Pike] 2013-10-16 04:02:45 PDT
Branislav, Vlado, the roles in https://wiki.mozilla.org/L10n:Teams:sk got confused, right?

Also, the previous versions of the page list Vlado as peer, which makes this a no-brainer.

Vlado does have an ssh key in ldap, the one from attachment 322438 [details].

The ldap group to set would be scm_l10n and hg level 1.
Comment 2 Pascal Chevrel:pascalc(PTO until Sept 2) 2013-10-16 04:18:38 PDT
thanks, moving to server-ops.
Comment 3 Vlado Valastiak [:wladow] @ Mozilla.sk 2013-10-16 12:17:09 PDT
(In reply to Axel Hecht [:Pike] from comment #1)
> Branislav, Vlado, the roles in https://wiki.mozilla.org/L10n:Teams:sk got
> confused, right?
> 
> Also, the previous versions of the page list Vlado as peer, which makes this
> a no-brainer.

Yeah, I have updated the wiki page to reflect the roles properly. I've been the product L10n peer since the very beginning back in 2003 with Branislav being the product L10n lead. And that's still the case, no change to that.

> Vlado does have an ssh key in ldap, the one from attachment 322438 [details].
> 
That's the correct one.

Thanks.
Comment 4 Rick Bryce [:rbryce] 2013-10-16 12:23:11 PDT
+scm_l10n.  Confirmed ssh_key is correct.
Comment 5 Axel Hecht [pto-Aug-30][:Pike] 2013-10-16 13:51:10 PDT
Rick, I'm reopening this, wladow has problems pushing, and my local ldap tool shows a few mismatches:

objectClass          inetOrgPerson, sambaAccount, posixAccount, ldapPublicKey, svnAccount

doesn't list hgAccount, and we'd also like to get level 1 hg up (not sure if that's the same thing)
Comment 6 Rick Bryce [:rbryce] 2013-10-16 14:04:33 PDT
(In reply to Axel Hecht [:Pike] from comment #5)
> Rick, I'm reopening this, wladow has problems pushing, and my local ldap
> tool shows a few mismatches:
> 
> objectClass          inetOrgPerson, sambaAccount, posixAccount,
> ldapPublicKey, svnAccount
> 
> doesn't list hgAccount, and we'd also like to get level 1 hg up (not sure if
> that's the same thing)

:pike  this is my mistake.  wladow had the correct bits, but hg access was not enabled.  I assumed incorrectly since he had scm_level_1 bit, that he had hg access.  This should be fixed now.

wladow is now configured for scm_level_1, scm_l10n, and Hg access.
Comment 7 Vlado Valastiak [:wladow] @ Mozilla.sk 2013-10-16 14:11:03 PDT
Thank you, Rick. Works like a charm now.
Comment 8 Vlado Valastiak [:wladow] @ Mozilla.sk 2013-10-16 14:11:44 PDT
Verified by pushing to l10n-central
http://hg.mozilla.org/l10n-central/sk/rev/384971377b30

Note You need to log in before you can comment on or make changes to this bug.