Changing sort order should reset to page 1

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: nONoNonO, Unassigned)

Tracking

({uiwanted})

Details

(Reporter)

Description

5 years ago
When you are browsing on amo on a certain category and then change the sort order, I'd expect to start on page 1 of the new order, but instead you stay on the page you were.

1. Go to <http://addons.mozilla.org/>;
2. Click on Featured under Explore or on See all behind Featured Extensions <https://addons.mozilla.org/en-US/firefox/extensions/?sort=featured>;
3. On the bottom of the page click on Next to go to page 2 <https://addons.mozilla.org/en-US/firefox/extensions/?sort=featured&page=2>
4. Now click on Most Users to sort by most users

Expected results:
You go to the start of the most users <https://addons.mozilla.org/en-US/firefox/extensions/?sort=users>

Actual results:
You go to page 2 of the most users <https://addons.mozilla.org/en-US/firefox/extensions/?sort=users&page=2>
Severity: normal → enhancement
Keywords: uiwanted
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.