Test failure for 17.0ESR: "Shockwave Flash does not appear in about:plugins - got 'false'" in testAddons/testPluginDisableAffectsAboutPlugins.js because plugin is still listed

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: cosmin-malutan, Assigned: mario.garbi)

Tracking

unspecified
x86
Linux

Firefox Tracking Flags

(firefox-esr17 disabled)

Details

(Whiteboard: [mozmill-test-failure], URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
In Esr17 we check if the plugin is listed in the about:plugins page and not if there is an property "disabled" in plugins content as we do for other branches.

Steps to reproduce:
1 Navigate the about:plugins
2 Open the Add-ons Manager
3 Disable a plugin
4 Navigate the about:plugins
5 Check if plugin is in page 
(It will be there and it shouldn't, if we skip step one the plugin won't be in the about:plugins page so I guess the page is cached somehow)

It doesn't reproduce on Windows and Mac only on Linux.
 
http://mozmill-daily.blargon7.com/#/functional/report/ec449c026814fd64783d738c0283a806
(Reporter)

Updated

5 years ago
status-firefox-esr17: --- → affected
(Reporter)

Comment 1

5 years ago
The machine on which I reproduced the failure is mm-ub-1304-32-3, I also seen this failure on mm-ub-1204-64-1 and mm-ub-1204-32-1.
Please use a different summary for a new bug. Otherwise most of our email applications will be confused. Once we know what a failure is about we should do it in any way.
Summary: Test failure "Shockwave Flash state is Disabled in about:plugins - got 'false'" in testAddons/testPluginDisableAffectsAboutPlugins.js → Test failure "Shockwave Flash state is Disabled in about:plugins - got 'false'" in testAddons/testPluginDisableAffectsAboutPlugins.js because plugin is still listed
Failed 4 times now with Ubuntu 12.04 and 13.04:
http://mozmill-daily.blargon7.com/#/functional/report/f54ca65f73fd56845c30b7ab7d08923b
http://mozmill-daily.blargon7.com/#/functional/report/f54ca65f73fd56845c30b7ab7d088946
http://mozmill-daily.blargon7.com/#/functional/report/f54ca65f73fd56845c30b7ab7d0867ec
http://mozmill-daily.blargon7.com/#/functional/report/f54ca65f73fd56845c30b7ab7d086029

Cosmin, if you can reproduce this manually, it's probably a Firefox bug. Please check on several machines, not just on the remote ones, to be sure it's not something set on those only.
Whiteboard: [mozmill-test-failure]
(Assignee)

Updated

5 years ago
Depends on: 927823
There is likely no chance to see this fixed for Firefox 17. Lets get this test disabled if it happens way too often.
(Assignee)

Updated

5 years ago
Assignee: nobody → mario.garbi
(Assignee)

Comment 5

5 years ago
Created attachment 818457 [details] [diff] [review]
Skip patch for ESR17

Disabled the test by skipping it for ESR17.

Linux report:
http://mozmill-crowd.blargon7.com/#/functional/report/f54ca65f73fd56845c30b7ab7d1fff94
Attachment #818457 - Flags: review?(andrei.eftimie)
Attachment #818457 - Flags: review?(andreea.matei)
Comment on attachment 818457 [details] [diff] [review]
Skip patch for ESR17

Review of attachment 818457 [details] [diff] [review]:
-----------------------------------------------------------------

Why are we skipping this on all platforms if just Linux is affected? Please do it only there.
Attachment #818457 - Flags: review?(andrei.eftimie)
Attachment #818457 - Flags: review?(andreea.matei)
Attachment #818457 - Flags: review-
(Assignee)

Comment 7

5 years ago
Created attachment 819600 [details] [diff] [review]
Skip patch v2

Updated the patch so that only Linux is disabled. Initially I understood that we want this test disabled for good on ESR17, thank you for clarifying this Andreea.
Attachment #818457 - Attachment is obsolete: true
Attachment #819600 - Flags: review?(andrei.eftimie)
Attachment #819600 - Flags: review?(andreea.matei)

Comment 8

5 years ago
Has been failing roughly 2-4 times a day.
I'll get the skip landed.
Priority: -- → P2
Summary: Test failure "Shockwave Flash state is Disabled in about:plugins - got 'false'" in testAddons/testPluginDisableAffectsAboutPlugins.js because plugin is still listed → Test failure "Shockwave Flash does not appear in about:plugins - got 'false'" in testAddons/testPluginDisableAffectsAboutPlugins.js because plugin is still listed
(Assignee)

Comment 9

5 years ago
Created attachment 819611 [details] [diff] [review]
Skip patch v3

Updated the indentation of the previous skip patch.
Attachment #819600 - Attachment is obsolete: true
Attachment #819600 - Flags: review?(andrei.eftimie)
Attachment #819600 - Flags: review?(andreea.matei)
Attachment #819611 - Flags: review?(andrei.eftimie)

Comment 10

5 years ago
Comment on attachment 819611 [details] [diff] [review]
Skip patch v3

Review of attachment 819611 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Disabled: http://hg.mozilla.org/qa/mozmill-tests/rev/c5a375b41667 (mozilla-esr17)
Attachment #819611 - Flags: review?(andrei.eftimie)
Attachment #819611 - Flags: review+
Attachment #819611 - Flags: checkin+

Comment 11

5 years ago
I'm guessing we should close this with WONTFIX as ESR17 won't see this fixed, and we just disabled the test on that branch.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox-esr17: affected → disabled
Resolution: --- → WONTFIX
Summary: Test failure "Shockwave Flash does not appear in about:plugins - got 'false'" in testAddons/testPluginDisableAffectsAboutPlugins.js because plugin is still listed → Test failure for 17.0ESR: "Shockwave Flash does not appear in about:plugins - got 'false'" in testAddons/testPluginDisableAffectsAboutPlugins.js because plugin is still listed
You need to log in before you can comment on or make changes to this bug.