Closed Bug 927406 Opened 6 years ago Closed 6 years ago

"this._slowSQLStartup.mainThread is not an object" {file: "resource://gre/components/TelemetryPing.js" line: 550}]' when calling method: [nsITelemetryPing::observe]

Categories

(Toolkit :: Telemetry, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
Tracking Status
firefox25 --- unaffected
firefox26 --- unaffected
firefox27 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: froydnj, Assigned: froydnj)

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #926119 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=29045295&tree=Mozilla-Central
Windows XP 32-bit mozilla-central opt test jsreftest on 2013-10-12 15:54:54 PDT for push 4861dbac22db
slave: t-xp32-ix-067

(bunch of non-failures highlighted by tbpl as failures)
16:04:26     INFO -  REFTEST TEST-START | Shutdown
16:04:26     INFO -  ************************************************************
16:04:26     INFO -  * Call to xpconnect wrapped JSObject produced this error:  *
16:04:26     INFO -  [Exception... "'[JavaScript Error: "this._slowSQLStartup.mainThread is not an object" {file: "resource://gre/components/TelemetryPing.js" line: 550}]' when calling method: [nsITelemetryPing::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: yes]
16:04:26     INFO -  ************************************************************
16:09:56  WARNING -  TEST-UNEXPECTED-FAIL | Shutdown | application timed out after 330 seconds with no output
This patch was originally done for bug 926119; vladan r+'d it in bug 926119 comment 7.
Carrying over r+ so that I can land it in this bug: while the patch fixes intermittent
issues, it doesn't totally fix the timeouts in the original bug.  So we're landing it
here and leaving the other bug open for intermittents.
Attachment #817837 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/e5c235dfea0a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
(I removed the keyword because this wasn't actually the cause of any intermittent failures)
In that case, the summary also needs updating, so my daily whine of bugs missing keyword doesn't trigger.. :-) (and so the summary is accurate)
Summary: Intermittent WinXP jsreftest TEST-UNEXPECTED-FAIL | Shutdown | application timed out after 330 seconds with no output → "this._slowSQLStartup.mainThread is not an object" {file: "resource://gre/components/TelemetryPing.js" line: 550}]' when calling method: [nsITelemetryPing::observe]
You need to log in before you can comment on or make changes to this bug.