The default bug view has changed. See this FAQ.

Add "From Legacy" services for SIP video to VidyoGateway

RESOLVED FIXED

Status

Infrastructure & Operations
AVOps: Vidyo
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: justdave, Assigned: Guillermo Huerta [Disabled MoCo account])

Tracking

Details

Attachments

(1 attachment)

We have no video-capable services enabled in VidyoGateway that are compatible with the SIP trunk from Asterisk.  We'd like to be able to enable users to call in with a video-capable SIP client.

Right now I can't seem to make it work.  I'm pretty sure the reason is because we only have H.323 services defined for inbound, and not SIP.

The "06" "07" and "08" services for SIP are currently defined as "To Legacy" only.  Those should be cloned with identical settings except for the direction being "From Legacy".

I'm guessing (but not positive) that it'll want to restart to apply the settings changes, so it probably needs CAB approval and done after hours.

Updated

4 years ago
Assignee: desktop-support → ghuerta
justdave: AIUI, fixing this bug would enable people to interact with the Vidyo system using free software clients. Is that correct? 

If so, do you or Guillermo have a progress report?

Gerv
(In reply to Gervase Markham [:gerv] from comment #1)
> justdave: AIUI, fixing this bug would enable people to interact with the
> Vidyo system using free software clients. Is that correct? 

That is correct.

> If so, do you or Guillermo have a progress report?

Guess it's waiting on Guillermo at this point.
Group: core-security
Component: Server Operations: Desktop Issues → Vidyo Infrastructure
Product: mozilla.org → Audio/Visual Infrastructure
Version: other → unspecified
Group: core-security → infra
guillermo: we've had a new version of Vidyo since this bug was filed. What's the story with it interoperating with SIP audio and video clients?

Gerv
Flags: needinfo?(ghuerta)
Gateway versions haven't changed, but I've made the change.  Please give this a try when you get a chance.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ghuerta)
Resolution: --- → FIXED
justdave: how can I test this? This bug doesn't explain how one might call in to a Vidyo call with a SIP client. I tried e.g. sip:5234@v.mozilla.com, but no response.

Gerv
Dialing extension 92 from a video-capable softphone logged into Mozilla's phone system should work.
Or sip:conf9xxx@mozilla.com  where xxx is the Vidyo conference room number (add the 9 in front)
justdave: I've tried the following SIP addresses in my desktop SIP client (Linphone), using a Sipgate account, and none of them work:

LON 341 Commons:
sip:conf5380@mozilla.com
sip:conf95380@mozilla.com
Gerv's Room:
sip:conf9894@mozilla.com
sip:conf99894@mozilla.com

Should these work?

My goal here, in case it's not obvious, is to allow people to use standards-compliant and open source software to dial in to Vidyo calls.

Can you get it working and let me know what config you used?

Gerv
Flags: needinfo?(justdave)
so it depends on the client ...  we have an SRV record in DNS pointing mozilla.com at pbx.mtv2.mozilla.com, however I've notice that YateClient, for example, doesn't look up the SRV record.  If you actually put pbx.mtv2.mozilla.com after the @ then it works (in YateClient).  Also essential to the process in this case is that you are not using an account.  It needs to be attempting direct SIP without the aid of an account provider.
Flags: needinfo?(justdave)
Having switched to direct-dial SIP, I now get the following results:

* Anything with "conf" prepended gives "User not found" as a textual message in the phone's UI. Are you sure that part is needed?

* sip:95380@pbx.mtv2.mozilla.com gives a voice saying "I'm sorry, that is not a valid extension"
* sip:5380@pbx.mtv2.mozilla.com rings and rings. Is it ringing the actual phone in the conference room?
* sip:99894@pbx.mtv2.mozilla.com rings once then hangs up on me
* sip:9894@pbx.mtv2.mozilla.com rings once then hangs up on me

Please can you give exact steps (and SIP URLs) you used to reproduce success?

Gerv
Flags: needinfo?(justdave)
And by "success", of course I mean "success connecting to a Vidyo conference room".

Gerv
Yes, the "conf" part is needed, and that's what I used to successfully connect:
sip:conf237@pbx.mtv2.mozilla.com (for the internal Asterisk conference room 237)
sip:conf9237@pbx.mtv2.mozilla.com (for the Vidyo conference room 237)

And without that, it does actually ring that extension if you put a valid extension there, assuming that extension is available to be dialed at the main menu if you call one of the outside phone numbers and use the IVR system.

We also have fail2ban watching the logs and it bans users for 6 hours if they get invalid extension 3 times (because it's commonly attacked), so you probably got banned.

Note that Vidyo gives you no audio indication that you've actually connected.  If there's nobody else already in there room, it'll just stop ringing and you'll hear silence.
Flags: needinfo?(justdave)
Using YateClient on the Mac:

Set Protocol to "sip", set Account to "none"
In the dial box, put in "conf9237@pbx.mtv2.mozilla.com"
Click "Call".
OK, I got audio working :-) Video still doesn't work. The call seems to pick H.263, which results in a light blue solid window in my Vidyo client. I can see a video preview locally, albeit that it only takes up a small bit of the preview window. 

Can anyone give some guidance as to which codecs this system should support?

The thing which was blocking it from working, it turns out, is that I had my Mozilla SIP account configured. Even if I tell Linphone not to register that account, the presence of this account in the config seems to break the ability to make a direct connection. (If I select that account as the account to use, it still doesn't work.) I assume it associates the two because the address I am dialling is at the same domain as the account. This may well be a Linphone bug.

I guess this problem will not be faced by most people trying to dial in this way, as they won't have accounts on our SIP server, so it's not going to be an issue.

I've updated
https://wiki.mozilla.org/Teleconferencing#Internet_calling_.28VoIP.29
- let me know if it's wrong.
 
Gerv
I believe it's set up to support both H.263 and H.264, Guillermo will have to let me know if that's not correct.

If you're logged into your Mozilla softphone account, then you should be able to get video just dialing x92 instead of using the sip: dialstring.
It is set to support both.
Can this bug be made public so I can point people at it and others can do some testing?

Gerv
Yep, I see nothing confidential in here.
Group: infra
QA Contact: tfairfield → moconnor
Maybe a wiki page with all the step for test and use this solution will be very useful.
Daniele: no-one is certain how to make it work reliably; that's what:
http://blog.gerv.net/2014/08/accessing-vidyo-meetings-using-free-software-help-needed/
is all about. If you know how to do it, please do write the wiki page, and give us a link here!

Gerv
I haven't gotten as far as Gerv, yet. Trying to simulate what an external contributor might use.

Context:
- Client: Jitsi (F/OSS, running on OS X)
- SIP Account: mozCallahad@ekiga.net (Free, from the Ekiga softphone team)
- Mozilla VPN not connected
- I have a Mozilla softphone (extension 817) and a personal Vidyo room (extension 9814)

The SRV record seems fine; I get identical results when dialing both @mozilla.com and @pbx.mtv2.mozilla.com

Calling 817@mozilla.com successfully rings my Mozilla-provided softphone.

Calling conf9814@mozilla.com appears to connect and remain connected, but I don't see/hear the room, the room doesn't see/hear me. I don't appear in the list of participants in the Vidyo room management dashboard.

Calling 99814@mozilla.com dials, responds with recording: "That is not a valid extension. Please hang up and try again."
Ooh! Dialing conf99814@pbx.mtv2.mozilla.com did successfully connect me to the Vidyo room, once.

I was able to see other participants, and they could hear me. No video from my camera, but I suspect that's a client problem. Trying again with another SIP client...
Linphone works! Reliably!

The only setting I had to change was Options -> Preferences -> Codecs -> Video codecs -> H263 -> Enable

(Not H263-1998; normal H263)

Once that was done, I could dial into conf99814@mozilla.com and everything (bidirectional A/V) worked.

I didn't even have to sign in with my Ekiga account -- the default dan@192.168.1.254 (local IP) account the Linphone tries to use worked just fine.
Dan: great! That's some of what justdave said in comments 12 and 13.

However, with the same settings, I can't connect to  conf99814@mozilla.com - it just hangs at "Contacting". However, conf9220@mozilla.com (my extension) works - sort of. (I get a very small video window, at any rate.) Do some of these rooms require an actual Vidyo user to be in them to exist, do you think?

Gerv
Created attachment 8472435 [details]
linphone-3.7.0-works.jpg

Attaching a screenshot proving that this is working for me, with relevant settings visible.

I'll write up a WikiMo page next week, after I've experimented with other clients and operating systems.
callahad: did your write-up ever make it to a wiki page? It would be great if we could update https://wiki.mozilla.org/Teleconferencing with clear and working instructions on how to connect into Vidyo via SIP. That's been my goal...

Gerv
Flags: needinfo?(dan.callahan)
(In reply to Dan Callahan [:callahad] from comment #22)
> Ooh! Dialing conf99814@pbx.mtv2.mozilla.com did successfully connect me to
> the Vidyo room, once.

For anyone who can't get the @mozilla.com SRV record to work, the direct hostname is now anonsip1.scl3.mozilla.com -- the mtv2 server no longer supports it.
(In reply to Gervase Markham [:gerv] from comment #26)
> callahad: did your write-up ever make it to a wiki page?

Unfortunately, I was only ever able to get it to work with LinPhone on OS X -- no other client I attempted to use on Mac OS X or Linux was able to successfully do video.

For audio, it was as simple as dialing sip:conf9<vidyo-ext>@mozilla.com and things seemed to Just Work, and those instructions are already on the Wiki.

Happy to take another run at testing stuff if it would be valuable.
Flags: needinfo?(dan.callahan)
I had it working on X-Lite on OS X back then when we were testing it.
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #29)
> I had it working on X-Lite on OS X back then when we were testing it.

Oh, X-Lite doesn't do point-to-point SIP.  It works dialing x92 while logged into Mozilla's phone system though.
justdave: anonsip1.scl3.mozilla.com doesn't respond to ping, and Linphone debug says:

message: eXosip_dnsutils_naptr_lookup: About to ask for 'anonsip1.scl3.mozilla.com NAPTR'
error: eXosip_dnsutils_naptr_lookup: res_query failed ('anonsip1.scl3.mozilla.com NAPTR')

I get the same error when trying @mozilla.com too.

message: eXosip_dnsutils_naptr_lookup: About to ask for 'mozilla.com NAPTR'
error: eXosip_dnsutils_naptr_lookup: res_query failed ('mozilla.com NAPTR')

Are you sure this is right? dig suggests anonsip1.scl3.mozilla.com doesn't have a NAPTR, and neither does mozilla.com...

Gerv
I had never heard of NAPTR before, wasn't aware anything needed it.  Everything I've touched before directly used the SRV record.  Yes, that's the correct domain name.

So obviously we need to set up that NAPTR record then.

The content of this record does *not* look very straightforward.  It's http://www.ietf.org/rfc/rfc2915.txt for future reference.
bug 1128415 has been filed to get the NAPTR set up.
Just to keep everyone up to date, bug 1128415 has been all but wontfixed as the system we use to manage our DNS does not currently support NAPTR records and trying to make it support them would be too large a task for a one-off like this.
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #27)
> For anyone who can't get the @mozilla.com SRV record to work, the direct
> hostname is now anonsip1.scl3.mozilla.com -- the mtv2 server no longer
> supports it.

This is a typo! The correct hostname is anonsip.scl3.mozilla.com. Perhaps that's why people were having problems!

Gerv
Product: Audio/Visual Infrastructure → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.