Closed Bug 927477 Opened 6 years ago Closed 6 years ago

"about:memory" >> "Measure" crashes FF 24.0 after some use

Categories

(Core :: Audio/Video, defect, critical)

24 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: zxspectrum3579, Unassigned)

References

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Use the browser for a while, and then open "about:memory" tab and press "Measure" button. (Freshly opened FF 24.0 allows use of "Measure" button without issue.)


Actual results:

FF 24.0 immediately crashes: here are two crash reports:

http://crash-stats.mozilla.com/report/index/6211d23e-5751-4379-8ba8-2a73f2131016
http://crash-stats.mozilla.com/report/index/d1e73db7-210f-4f4f-912d-45db92131015



Expected results:

The page should display FF memory map.
Are you able to reproduce the crash?
Can you test with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Severity: normal → critical
Crash Signature: [@ mozilla::MediaDecoderReader::VideoQueueMemoryFunctor::operator()(void*) ]
Flags: needinfo?(zxspectrum3579)
Keywords: crash
Hi, Loic; thanks for reply.

I will try to test is in a clean profile, though it may take sometime as the crash does not happen immediately after fresh load.

Though I looked at other people's reports with this crash and found no common theme yet -- it terms of add-ons/plugins, so I am not sure what difference clean profile will do. But maybe I have missed something.
Flags: needinfo?(zxspectrum3579)
You have many add-ons, so maybe one of them is faulty. And opening the page about:memory may be just the trigger of another underlying bug in a different component of the Firefox code.

In addition, could you try to know if it happens on a specific site?
The crash does not happen upon the opening "about:memory" page, it happens when "Measure" button is pressed.

I checked other crash reports that are the same; there are some them have none of addons/plugins I have. And I found that no-extensions FF crash report already exists (from some other contributor):

http://crash-stats.mozilla.com/report/index/b1ef002c-a11e-4af5-b6cb-98bae2131002

("{972ce4c6-7e08-4474-a285-3208198ce6fd}" which is listed as extension is not actually extension, but some obligatory tag for folder/id inside "Extensions" folder in FireFox installation path).



Common signature "@ mozilla::MediaDecoderReader::VideoQueueMemoryFunctor::operator()(void*)" of all of those crashes makes me guess that the crash happens near the end of "Measure" procedure, where FF tries to measure video-related memory map such one of those:

    1.40 MB ── canvas-2d-pixel-bytes
    6.26 MB ── gfx-d2d-surfacecache
    4.10 MB ── gfx-d2d-surfacevram
   41.33 MB ── gfx-d2d-vram-drawtarget
    9.94 MB ── gfx-d2d-vram-sourcesurface
   22.61 MB ── gfx-surface-image
    0.00 MB ── gfx-textures
          0 ── ghost-windows
   53.48 MB ── gpu-committed
   93.61 MB ── gpu-dedicated
   14.55 MB ── gpu-shared
  565.13 MB ── heap-allocated
  609.79 MB ── heap-committed
   44.74 MB ── heap-committed-unused
      7.91% ── heap-committed-unused-ratio
    3.39 MB ── heap-dirty
  135.92 MB ── heap-unused
   11.25 MB ── images-content-used-uncompressed
  267.00 MB ── js-gc-heap
    2.41 MB ── js-main-runtime-temporary-peak
          0 ── low-commit-space-events
  983.14 MB ── private
1,009.56 MB ── resident
   24.05 MB ── storage-sqlite
1,584.12 MB ── vsize
Component: Untriaged → Video/Audio
Product: Firefox → Core
Considering that there are plenty of crash reports on this bug, including in a clean profile, should the status be changed to "Confirmed"?
Are you able to reproduce this in a current nightly build?
Pretty sure this crash is fixed by the patch in bug 887968, which should be in Firefox 25 (beta).
Status: UNCONFIRMED → NEW
Depends on: 887968
Ever confirmed: true
Reporter, can you download and install Firefox Beta to confirm it's fixed or not on your side, please.
http://www.mozilla.org/en-US/firefox/all-beta.html
Flags: needinfo?(zxspectrum3579)
Thanks to Matthew and Loic for the prompt. I am using beta of 25th version since yesterday, and pressing "measure" on "about:memory" page still did not result in a crash. There is even hope that other types of crashes that FF24 has will not follow.
Flags: needinfo?(zxspectrum3579)
Closed as worksforme as it's not reproducible anymore in FF25. Feel free to reopen if the issue is back.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.