Closed Bug 927568 Opened 7 years ago Closed 7 years ago

Marionette curBrowser.frameManager.currentRemoteFrame is null when running reftests oop

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(firefox25 wontfix, firefox26 wontfix, firefox27 fixed, b2g-v1.2 fixed)

RESOLVED FIXED
mozilla27
Tracking Status
firefox25 --- wontfix
firefox26 --- wontfix
firefox27 --- fixed
b2g-v1.2 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(2 files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=29206998&tree=Cedar

12:43:06     INFO -  System JS : ERROR chrome://marionette/content/marionette-server.js:2196
12:43:06     INFO -                       TypeError: this.curBrowser.frameManager.currentRemoteFrame is null

Haven't had time to investigate, but this happens when running with:
browser.tabs.remote = True and from within an <iframe mozbrowser remote>
This is the patch needed to reproduce the problem seen on Cedar. I still haven't found time to look into this.
For context the reftest.browser.iframe.enabled pref causes the js harness to be created within an <iframe mozbrowser> instead of a <xul:browser>

http://mxr.mozilla.org/mozilla-central/source/layout/tools/reftest/reftest.js#260
Actually, I think this was a really simple fix, should have looked into it earlier. I believe the problem is that we have a boolean clause of "!a || b && c" when we actually want "(!a || b) && c".

I pushed this to cedar, we'll see if this fixes it, and which errors will come next:
https://tbpl.mozilla.org/?tree=Cedar&rev=b1ae1f0f5bd4
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
Attachment #819114 - Flags: review?(mdas)
Comment on attachment 819114 [details] [diff] [review]
Patch 1.0 - fix misplaced null check

Review of attachment 819114 [details] [diff] [review]:
-----------------------------------------------------------------

Aha, yes!  Good catch, thanks for the patch.
Attachment #819114 - Flags: review?(mdas) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/9445d7191df4

This didn't end up being the cause of the problem, I'm still seeing the same failure pattern on Cedar. It should still be fixed regardless though.
https://hg.mozilla.org/mozilla-central/rev/9445d7191df4
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.