SSL stress test hangs on Linux.

RESOLVED INVALID

Status

P2
normal
RESOLVED INVALID
18 years ago
16 years ago

People

(Reporter: wtc, Assigned: kirk.erickson)

Tracking

3.2.1
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I built NSS 3.3 on Red Hat Linux 7.1 and ran all.sh
repeatedly.  At one point the SSL stress test was
hung and the 'ps' command's output was:
wtc      13589 13580  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13600 13589  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13601 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13602 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13603 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13604 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13605 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13606 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13607 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13608 13600  0 19:11 pts/0    00:00:00 selfserv -D -p 8443 -d ../server
wtc      13610 13580  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss
wtc      13613 13610  0 19:11 pts/0    00:00:00 [strsclnt <defunct>]
wtc      13986     1  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss
wtc      13987     1  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss
wtc      13988     1  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss
wtc      13989     1  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss
wtc      13990     1  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss
wtc      13991     1  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss
wtc      13992     1  0 19:11 pts/0    00:00:00 strsclnt -q -p 8443 -d . -w nss

This bug may be related to bug 70643 in that the internal manager
thread (pid 13613) for the strsclnt process (pid 13610) died (shown
as 'defunct').  Apparently all the other threads in strsclnt had
terminated and were adopted by the init process (pid 1) because
their parent (the internal manager thread) was dead.

The code was compiled on box.red.iplanet.com and the tests were
run on nautica.red.iplanet.com.
(Reporter)

Comment 1

18 years ago
Correction: all the other threads in strsclnt were still alive.
They had not terminated, but they were adopted by the init process
(pid 1).
(Reporter)

Comment 2

18 years ago
Also note that pid 13580 is the process '/bin/sh ./all.sh'.

Comment 3

18 years ago
Similar hangs are seen every 100 runs on NT on the tinderbox
(Reporter)

Updated

17 years ago
Priority: -- → P2
Target Milestone: --- → 3.4
(Reporter)

Comment 4

17 years ago
Changed the QA contact to Bishakha.
QA Contact: sonja.mirtitsch → bishakhabanerjee
(Reporter)

Comment 5

17 years ago
Set target milestone to NSS 3.5.
Target Milestone: 3.4 → 3.5
(Assignee)

Comment 6

17 years ago
Set target milestone to NSS 3.6.
Target Milestone: 3.5 → 3.6
(Reporter)

Comment 7

16 years ago
Let's look into this in 3.7.  It's okay to resolve it
INVALID or WONTFIX if we can't reproduce it on recent
Linux releases (with the current kernel and glibc
patches applied).
Target Milestone: 3.6 → 3.7
(Assignee)

Comment 8

16 years ago
I've lost track of the version numbers.
Here's what I have on box - my work machine:

kernel-2.4.7-10
glibc-2.2.4-13

Is this sufficient?
(Reporter)

Comment 9

16 years ago
I think those are the versions out of the box.

You should go to http://www.redhat.com/apps/support/errata/
to download the latest kernel and glibc patches.
(Assignee)

Comment 10

16 years ago
Do I need to force the install?
or do I need to start gathering the dependent rpms?

Downloaded from:
http://mirror.hiwaay.net/redhat/redhat/linux/updates/7.2/en/os/i686/
Index of /redhat/redhat/linux/updates/7.2/en/os/i686

glibc-2.2.4-30.i686.rpm
kernel-2.4.18-17.7.x.i686.rpm
kernel-bigmem-2.4.18-17.7.x.i686.rpm
kernel-debug-2.4.18-17.7.x.i686.rpm
kernel-smp-2.4.18-17.7.x.i686.rpm

[root@box 92759]# rpm -Uhv *.rpm
error: failed dependencies:
	glibc-common = 2.2.4-30 is needed by glibc-2.2.4-30
	modutils >= 2.4.18 is needed by kernel-2.4.18-17.7.x
	dev < 3.2-7 conflicts with kernel-2.4.18-17.7.x
	iptables < 1.2.5-3 conflicts with kernel-2.4.18-17.7.x
	bcm5820 < 1.81 conflicts with kernel-2.4.18-17.7.x
	modutils >= 2.4.18 is needed by kernel-bigmem-2.4.18-17.7.x
	dev < 3.2-7 conflicts with kernel-bigmem-2.4.18-17.7.x
	iptables < 1.2.5-3 conflicts with kernel-bigmem-2.4.18-17.7.x
	bcm5820 < 1.81 conflicts with kernel-bigmem-2.4.18-17.7.x
	modutils >= 2.4.18 is needed by kernel-debug-2.4.18-17.7.x
	dev < 3.2-7 conflicts with kernel-debug-2.4.18-17.7.x
	iptables < 1.2.5-3 conflicts with kernel-debug-2.4.18-17.7.x
	bcm5820 < 1.81 conflicts with kernel-debug-2.4.18-17.7.x
	modutils >= 2.4.18 is needed by kernel-smp-2.4.18-17.7.x
	dev < 3.2-7 conflicts with kernel-smp-2.4.18-17.7.x
	iptables < 1.2.5-3 conflicts with kernel-smp-2.4.18-17.7.x
	bcm5820 < 1.81 conflicts with kernel-smp-2.4.18-17.7.x
(Reporter)

Comment 11

16 years ago
Do not force the install.  You should install
the dependent rpms, too.
(Assignee)

Comment 12

16 years ago
Needed to download i386 rpms too.  
This combo installed on box:

dev-3.3-4.i386.rpm
glibc-2.2.4-30.i686.rpm
glibc-common-2.2.4-30.i386.rpm
glibc-devel-2.2.4-30.i386.rpm
glibc-profile-2.2.4-30.i386.rpm
hwcrypto-1.0-3.i386.rpm
iptables-1.2.5-3.i386.rpm
iptables-ipv6-1.2.5-3.i386.rpm
kernel-2.4.18-17.7.x.i686.rpm
kernel-bigmem-2.4.18-17.7.x.i686.rpm
kernel-debug-2.4.18-17.7.x.i686.rpm
kernel-smp-2.4.18-17.7.x.i686.rpm
modutils-2.4.18-3.7x.i386.rpm
modutils-devel-2.4.18-3.7x.i386.rpm
openssl-0.9.6b-28.i386.rpm
openssl-devel-0.9.6b-28.i386.rpm
openssl-perl-0.9.6b-28.i386.rpm

Added sonja.mirtitsch@sun.com to the list.

(Assignee)

Comment 13

16 years ago
Sonja,  let me know if you see the hangs on box go away.
If the upgrade resolves this problem, we will mark this INVALID.
Status: NEW → ASSIGNED

Comment 14

16 years ago
I have not seen these hangs in a long time, and we are not supporting redhat 7.1
anymore.
Please close.
(Assignee)

Comment 15

16 years ago
Sonja reported that we're unable to reproduce.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.