Activity is sometimes broken under monkey tests

RESOLVED DUPLICATE of bug 924971

Status

RESOLVED DUPLICATE of bug 924971
5 years ago
5 years ago

People

(Reporter: cyu, Assigned: alive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
This is found in reproducing bug 878366 on latest m-c and gaia revision f795c01. Here is the STR:
* Open the camera app
* Open the messages app
* Add an attachment, select camera
* Before camera preview is shown, quickly tap the screen repeatedly in random locations (monkeys don't wait until the camera becomes ready, do they?)
* Then chances are that we'll see the normal camera app UI instead of the activity UI.

I've tested picking a picture from the gallery, and I can also reproduce the problem.
The key to reproducing is the camera app must be there as in step 1.
Yes, I heard about this.
Inline activity has a chance to become the real app. Still don't know why.

Anther STR:
0. Open gallery app
1. Long press on homescreen to inovke choose wallpaper UI
2. Select gallery

Repeat 1.2. sometimes the gallery activity is loaded as index.html instead of pick.html or whatever.
Regression but still don't know gaia or gecko bug. nom koi?
Assignee: nobody → alive
blocking-b2g: --- → koi?
I wonder this is a dupe.
E/GeckoConsole(  415): [JavaScript Error: "NS_NOINTERFACE: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]" {file: "jar:file:///system/b2g/omni.ja!/components/ActivityWrapper.js" line: 47}]

The activity wrapper fails to send the activity object to the callee, so callee doesn't know it's in activity mode.
That's a dupe of bug 924971
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924971

Updated

5 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.