[B2G][Helix][WIFI][wangyuguo]Help to check the performance about wifi.

RESOLVED INVALID

Status

P1
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perf-reviewed])

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

1.We want to know the max number of connections(indicate maximum number) when we set the device as hostap.
2.We want to know the wifi whether support WEP,AES,TKIP,AES+TKIP?
3.We want to know the wifi hostap enabled whether connect the network and open the data communication as a must condition.


Actual results:

1.I have not find the code about max number connection as hostap in gaia.
2.I think the system support WEP,AES,TKIP,AES+TKIP,please help check.
3.our systme can open the hostap without any network communication.


Expected results:

2.The system should support WEP,AES,TKIP,AES+TKIP.
3.Enable the hostap should ensure the network communication is ok.
(Reporter)

Updated

5 years ago
Severity: normal → critical
Priority: -- → P1
Tim, can you help with these wifi questions or point them in the right direction?
Component: General → Wifi
Flags: needinfo?(timdream)
Whiteboard: [perf-reviewed]
I don't think our Wifi Hotspot feature support limiting number of clients.
Flags: needinfo?(timdream) → needinfo?(wchang)
However, it looks like we have two setting entries available to limit the number of DHCP IPs available.

   'tethering.wifi.dhcpserver.startip': '192.168.1.10',
   'tethering.wifi.dhcpserver.endip': '192.168.1.30',

If by limiting that's what to use, use it :)
Ken,

Can you help with the questions here in comment 0?

Can you also check if what Tim suggests in comment 3 are utilized?

Thanks!
Flags: needinfo?(wchang) → needinfo?(kchang)
> Steps to reproduce:
> 
> 1.We want to know the max number of connections(indicate maximum number)
> when we set the device as hostap.
It's depending on the capability of wifi hardware and its driver. Of course, it's also depending on the dhcp server ip pool. Currently, the ip pool range for dhcp server is 192.168.1.10 ~ 192.168.1.30.

http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/NetworkManager.js?from=networkmanager.js%20#l101

> 2.We want to know the wifi whether support WEP,AES,TKIP,AES+TKIP?
We support no security mode, AES + TKIP and AES. It depends on the how netd handle is working below.  
http://androidxref.com/4.3_r2.1/xref/system/netd/SoftapController.cpp#131

> 3.We want to know the wifi hostap enabled whether connect the network and
> open the data communication as a must condition.
Maybe you should file a gaia bug for this. But it should not be limited in gecko.
Severity: critical → normal
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 6

5 years ago
Vincent had updated.
Flags: needinfo?(kchang)
You need to log in before you can comment on or make changes to this bug.