bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Fix out of date Fx warning flow

VERIFIED FIXED in 2013Q4

Status

support.mozilla.org
Knowledge Base Software
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: verdi, Assigned: rrosario)

Tracking

unspecified
2013Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=wiki p=1 s=2013.22)

(Reporter)

Description

5 years ago
Mozilla.org has implemented a check on the download page to see if you are on the latest version. If you are not, they send you to a sumo article https://support.mozilla.org/kb/update-firefox-latest-version

The problem is that if you visit that page with an old enough version of Firefox, SUMO will show a warning that you are out of date and give you a link back to the download page.

Demo: http://people.mozilla.org/~mverdi/video/update-cycle.mp4

There are a couple of things we should consider doing:
1. Don't show the out of date sumo warning on this article since the user is obviously trying to learn about updating.
2. Change the sumo warning to point to the update instructions instead of a download link. One issue here is that if updater mechanism is broken in your copy of Firefox you could get stuck.
3. Create a special sumo page for this link with simplified instructions.
4. Update the current sumo page instead of creating a new one.
5. All of the above?
(Reporter)

Comment 1

5 years ago
We just talked about this https://etherpad.mozilla.org/sumo-p-2013-10-17 and decided we should remove the warning from this article and A/B test a much shorter version of the article.

Updated

5 years ago
Whiteboard: u=user c=wiki p= s=2013.22

Updated

5 years ago
Priority: -- → P3
Target Milestone: --- → 2013Q4
(Assignee)

Comment 2

5 years ago
We are going to special case this one KB page so that the warning doesn't show for it. Probably just some css tomfoolery needed. Like add `class="DONT-SHOW-ME-THE-WARNING"` to the `<body/>` and `body.DONT-SHOW-ME-THE-WARNING #warning { display: none; }`

easy peasy.
Whiteboard: u=user c=wiki p= s=2013.22 → u=user c=wiki p=1 s=2013.22
(Assignee)

Comment 3

5 years ago
moo
Assignee: nobody → rrosario
(Assignee)

Comment 6

5 years ago
Deployed to prod now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
Viewed https://support.mozilla.org/kb/update-firefox-latest-version and got no warning. Other articles display the warning.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.