[GP] 1.2 builds are using the wrong l10n repository

VERIFIED FIXED

Status

Firefox OS
General
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tchevalier, Assigned: Geeksphone)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The 1.2 builds available at http://downloads.geeksphone.com/ are using the wrong l10n repository (https://hg.mozilla.org/gaia-l10n/) instead of the 1.2 l10n repository: https://hg.mozilla.org/releases/gaia-l10n/v1_2/

Consequences are:

- Some bugs due to the entity name, see attachment.

- L10n QA is not as easy as on 1.1, especially for people outside of the l10n teams

- Users are complaining about English strings in the UI


Could you please switch to the right l10n repo? If not, is there something blocking?

Thanks!

BTW, you should also switch 1.1 repository to https://hg.mozilla.org/releases/gaia-l10n/v1_1/
(Reporter)

Comment 1

4 years ago
Created attachment 818581 [details]
Screenshot notification bug
Thanks for filing this bug Théo. I agree that this is an important issue, and it would be great to have this resolved quickly!
(Assignee)

Comment 3

4 years ago
Thanks for the info. I sent a mail to @delphine to get some more info about the l10n folders layout. Once we know how they are organized we will make the needed changes.
Status: NEW → ASSIGNED
(Reporter)

Comment 4

4 years ago
You are now using the right repositories, but in the process, you removed a lot of locales (almost all!) on 1.1, 1.2 and maybe 1.3 (didn't check)

The current available locales are ar, en-US, fr, zh-CH

Could you please look at this? Thanks!
(Assignee)

Comment 5

4 years ago
Working on it. Fix soon :)
(Assignee)

Comment 6

4 years ago
Fixed. All images from today will have the languages defined in languages-dev.json (languages-all.json if it's master).
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

4 years ago
Verified fixed on Peak 1.2 with 20131022205731

Thanks!
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.