can't search body and to on IMAP inbox

VERIFIED DUPLICATE of bug 89052

Status

VERIFIED DUPLICATE of bug 89052
18 years ago
11 years ago

People

(Reporter: Brade, Assigned: naving)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I can't search my IMAP inbox using "Search Messages" if I do this:
 * choose "Any of the following" radio button
 * To contains (any text here)
 * Body contains "ftp" (without quotes of course)
 * Click Search button.
I get this error message:
 The current command did not succeed.  The mail server responded: Missing
required argument to Search body.

Notes:  If I change the body text to be "hello" (instead of ftp) it works fine.
If I change the order of the To/Body then I don't get the error either.

I am using a NS branch (installed) version of 6.1 (from 7/22) on NT4.

Comment 1

18 years ago
This sounds like it may be a duplicate of a bug Seth recently fixed on the
trunk. See bug 89052. cc seth.
yes, this looks like a dup of #89052

we were building up bad IMAP search queries.  (yikes!)

on today's trunk, I'm able to search on any, to contains "test", body contains "ftp"

brade, please verify.

*** This bug has been marked as a duplicate of 89052 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Works okay for me using aug06 commercial trunk build, win98.  I'd tried on the
branch and it failed.  Marking verified (duplicate).
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

11 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.