Support "draft" articles

RESOLVED DUPLICATE of bug 770390

Status

developer.mozilla.org
General
RESOLVED DUPLICATE of bug 770390
5 years ago
5 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:feature])

(Reporter)

Description

5 years ago
What problems would this solve?
===============================
Currently, there's no real way to indicate that an article is an incomplete draft, other than adding the {{draft}} macro, which just shows a box at the top of the article. We need a consistent way to do this that ensures that no matter how far down the reader has scrolled, they know the content is a draft.

Who would use this?
===================
All writers/contributors.

What would users see?
=====================
When saving, there should be a flag that indicates the content is not complete. Perhaps a "save as draft" checkbox near the save button.

When reading content, some kind of background color with watermark "Draft" text would be ideal.

What would users do? What would happen as a result?
===================================================
See above.

Is there anything else we should know?
======================================
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 770390
You need to log in before you can comment on or make changes to this bug.