[Gallery] Share button not working

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Gallery
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: marcia, Assigned: johnhu)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

Attachments

(3 attachments)

Buri, while running:

Gaia   616e87af0133496620aea89f21ca5d37acedf466
SourceStamp 423b9c30c73d
BuildID 20131017040202
Version 27.0a1

STR:
1. Go to Gallery and select an individual pictures
2. Press the "share" icon

Expected: I would get options to share the photo
Actual: nothing happens

The share activity seems to work fine in the music app. It works as well using:

Gaia   3d4f1107e6e91e5f5649edc0f2565ac837111d7d
SourceStamp 9f63bbc00527
BuildID 20131016040202
Version 27.0a1
Created attachment 818598 [details]
Log captured while trying to share a photo in gallery
Regression range:

Works: 

Gaia   3d4f1107e6e91e5f5649edc0f2565ac837111d7d
SourceStamp 9f63bbc00527
BuildID 20131016040202
Version 27.0a1

Broken:

Gaia   616e87af0133496620aea89f21ca5d37acedf466
SourceStamp 423b9c30c73d
BuildID 20131017040202
Version 27.0a1
Keywords: regressionwindow-wanted
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.3?
Is this reproducing on 1.2?
Keywords: qawanted

Comment 4

5 years ago
This did not reproduce on the latest 1.2 build.

Buri v 1.2 Mozilla RIL
Build ID: 20131017004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/7ca5d1e81d37
Gaia: dbcc171eae6b4d9d168a48291d5ea54c7580561a
Platform Version: 26.0a2
Keywords: qawanted
QA Contact: nkhristoforov

Comment 5

5 years ago
Created attachment 826629 [details]
20131104_125056.jpg

I tested with Nexus-4 Devices, Able to share the pictures from Gallery Application. I attached the screen shot for the Same.

Gecko 	  fd5be0de78d827056832a65431bb43b3c5311a7b
Gaia  	  34c6aeb027728624a478f299a34c28a7f7b43e64
Build-ID    20131021141837
P.version   27.0a1
Device     Nexus-4

Comment 6

5 years ago
Marking this a blocker because share button does not work on master for the gallery app
blocking-b2g: 1.3? → 1.3+
Tested with an updated 1.3 build, with the 1.2 base image and the issue still reproduces on the Buri device:

Gaia   7243b75041c93bc7deb240131748d0b164f3f0b0
SourceStamp 7b014f0f3b03
BuildID 20131113040200
Version 28.0a1

Comment 8

5 years ago
John,

Could you please take a look at this?

Thanks!
Hema
Assignee: nobody → johu
Created attachment 832815 [details]
unable to reproduce with the same version

Hi Marcia,

I had tested in Inari, ZTE Open, Helix, and Buri. I can't reproduce it with the same version.

The attached video is tested on Buri with the same build version: 20131017040202. I flash them from PVT server. Is anything I missed???
Flags: needinfo?(mozillamarcia.knous)
John: I retested this today on Buri with the latest Base image that came out (11-15), and I could not reproduce the issue after full flashing the latest pvt build on top of it. I did see it using previous builds, and I was not testing with an engineering build (not sure if that makes any difference or not).

Resolving this as WFM and will reopen if it is seen again.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → WORKSFORME
Interestingly, using the updated 1.2 11-15 base image with the latest 1.2 build I still see this bug on one device. I picked several photos from the gallery (some taken with the camera, some not) and it happens with all of them. I tried a video and it worked. This seems to be happening intermittently even though Comment 4 suggests it worked in that build.  I used the same build on jammink's phone and it works on his device using a similar build, and I flashed a different 1.2 device using: 

Gaia   7a23f8c53ba97da9c63a7275b36d155b4526a639
SourceStamp 3e8b854a992e
BuildID 20131118004001
Version 26.0

and it also works fine

Anyone have any ideas on why this might be happening on some devices?
You need to log in before you can comment on or make changes to this bug.