Tab dropdown list is not visible when only a few tabs are open

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: André Pirard, Unassigned)

Tracking

21 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: workaround: see comment #8, comment #2)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512194445

Steps to reproduce:

Why put extra logic in Firefox to remove the Tab list dropdown when there's plenty of room for it (when tabs are fewer)?
I counted, especially since Nevercrash dims the tabs, that it takes me more that 15 seconds to scan the tabs by hovering the mouse and see the tips over a full line, as opposed to 1 or 2 with the dropdown.
Please leave that dropdown list permanent.  It hurts nothing and no one. Thanks.

Comment 1

5 years ago
The tab list dropdown menu isn't being removed as far as I know... Did you hear somewhere that it is?  If you don't see it in your Firefox, you can open the toolbar customization window and make sure the "List all tabs" button is in your toolbar.
Flags: needinfo?(a_pirard)

Comment 2

5 years ago
Since Firefox 12 the dropdown only appears when there are enough tabs to overflow the tab bar (see bug 714281).

If you want it visible all the time, you can add this line to userChrome.css:

#alltabs-button {visibility:visible !important;}

Comment 3

5 years ago
Ah, thanks, mjh.  This is probably a wontfix then, but I'll let someone else make that call.
Blocks: 714281
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
Flags: needinfo?(a_pirard)
Whiteboard: [wontfix?]
(Reporter)

Comment 4

5 years ago
I did not hear anything, I saw it.
Where did you hea
(Reporter)

Comment 5

5 years ago
Created attachment 819295 [details]
t0.png

see comment
(Reporter)

Comment 6

5 years ago
Created attachment 819296 [details]
t1.png

see comment
(Reporter)

Comment 7

5 years ago
Thanks for your replies.
I did not hear anything, I saw it of course if it annoys me.
Where did you hear it's in the toolbar? It's in the tab bar. I see no "List all tabs" button.

I had no chrome folder, I've had a hard time of a geek finding where that userChrome.css file must be and after adding "#alltabs-button {visibility:visible !important;}" with and without #, I saw no change at all.
Certainly not for the general user !!!

I strongly contest such kinds of modifications, probably based on the idea that the dropdown arrow is useless if the tabs are few.  First, the idea is highly inappropriate because the person who does not need the arrow just doesn't click it, and anyone complaining about its presence would be a pest, but if you remove it the person who needs it just cannot click it. Secondly, the pictures I just uploaded show very clearly the inconvenience: causing people to spend more than 10 seconds to scan the titles of the page is a very bad idea.

So, either we consider this bug selfish and to be introduced by as many persons as needed and I'm asking a really working workaround, or we consider it's for the benefit of the whole Firefox community and that non-improvement should be removed.
I'd love a working workaround anyway, thanks.

Comment 8

5 years ago
André, I found this add-on that you can install to make it permanent. This will be the easiest way to fix it:

https://addons.mozilla.org/en-US/firefox/addon/permanent-listalltabs/

I'm going to WONTFIX the bug, because it's highly unlikely to be changed in Firefox itself. But at least there's an easy workaround. :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Whiteboard: [wontfix?]
(Reporter)

Comment 9

5 years ago
I'm recovering from a mid-air crash, and I find your answer very disappointing.
First, saying that Mozilla will not fix that bug because it's highly unlikely that they will fix it is the strangest reason there is.  Secondly, the bug that deserved a WONTFIX is the bug that introduced this stupid problem and not this one.

This is what I was writing before the crash...

I browsed that bug, and more exactly culprit bug 626854, and I read:

- They [the tabs] get highlighted and have tooltips.

Not exactly speaking of the same thing, but still, I wouldn't call highligted the tabs in my pictures.

 - Side issue in this case is [the dropdown list] exposing app tab titles, but as you point out they do have tooltips as well for that.

More to the point, is "have tooltips" a good argument if it needs a not considered good 10 seconds to find the right tab?
My scan did not find the motivation for hiding that button.
If I read the words in the bug description is "spin-off" and it sounds that it is an internals, technical fight between bugs much more than user convenience.

These kinds of so-called improvements are like removing (instead of greying) a menu entry when it does not apply and cause the feature to no longer be used because the users no longer see that it exists. Same for needlessly removing http:// from the navigation bar, causing a good 10 bugs and having the poor old people believe that what they call Internet addresses really no longer contain http://.
(Reporter)

Comment 10

5 years ago
Thanks mjh563, that addon works great and, beside the general interest of a fix, only two questions remain:
- can this "feature of Firefox" be called annoying if it caused someone going all the way writing an addon instead of removing a patch?
- do addons exist to fix bugs in other addons that the author WONTFIX, and does applying that fix without the addon cause a bug that is fixed by a third addon?
;-)
Back to being serious, something that still has to be invented is a "bug solution" box below the "bug description" box so that the bugzilla, launchpad or whatever be useful to the user (too) by telling him in the right place and with his own words what to do to solve his problem.  What you did, in fact, but in mid-air: many a one will have stopped reading well before that.

Updated

5 years ago
Summary: Missing tab dropdown list is a pain → Tab dropdown list is not visible when only a few tabs are open
Whiteboard: workaround: see comment #8, comment #2
(In reply to André Pirard from comment #0)
> ... especially since Nevercrash dims the tabs, ...

So that add-on makes tab titles almost illegible. Seems like you should report this undesirable behavior to the add-on's author rather than having to resort to a menu to read tab titles.
(Reporter)

Comment 12

5 years ago
(In reply to Dão Gottwald [:dao] from comment #11)
> (In reply to André Pirard from comment #0)
> > ... especially since Nevercrash dims the tabs, ...
> 
> So that add-on makes tab titles almost illegible. Seems like you should
> report this undesirable behavior to the add-on's author rather than having
> to resort to a menu to read tab titles.

No thank you. They could reply WONTFIX like Mozilla does.
Plus, think twice, what would be the use if the tabs show only 6 characters of the title?
Much unlike restoring the former behavior or Firefox, nobody thought of that alternative.
All my thanks went to Siddhartha Dugar for being the sensible one, and generous.

Updated

4 years ago
Duplicate of this bug: 1079669
You need to log in before you can comment on or make changes to this bug.