[keon] No cell connection with v1.2

RESOLVED FIXED

Status

Firefox OS
RIL
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rillian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [from-geeksphone])

Attachments

(1 attachment)

Phone type (Keon, Peak, other): Keon
OS version (Settings>Device information>More information>): 1.2.0.0-prerelease
Build Identifier (...>More information>): 20131016225213
Update channel (...>More information>): default

Steps to Reproduce:
1) Flash keon with images-keon-v1.2-2013-10-16.Gecko-6cdd9bd.Gaia-dbcc171.zip


Expected Result:
Normal cell service

Actual Result:
Phone says "Emergency calls only" displays no signal bars or data connection.

Is this issue sometimes or always reproducible: 
I've seen this with both the 2013 Oct 14 and 2013 Oct 16 images. The previous 1.2 image, I think from Oct 10, worked.
(Reporter)

Comment 1

4 years ago
No change with the Oct 18 build.
(Reporter)

Comment 2

4 years ago
No change with images-keon-v1.2-2013-10-22.Gecko-6f78b94.Gaia-b26a06a.zip

How can I debug this? Roland said there's a bug with nightly (1.3) which broke Canadian SIM compatibility. Could this be the same issue on 1.2?
(Reporter)

Comment 3

4 years ago
Cycling power after the flashing the 2013 October 22 build allowed me to reconnect. So this is fixed somewhere in the last 4 days.
(Reporter)

Comment 4

4 years ago
Well, I had signal bars, but no data connection. after power cycling again, back to no signal bars and "emergency calls only".
(Reporter)

Comment 5

4 years ago
Usually I get signal bars and voice/sms works, sometimes not. Data doesn't work in either case. I've tried with CityFone and SpeakOut SIMs.
(Reporter)

Comment 6

4 years ago
Created attachment 821465 [details]
radio.log

Following the instructions from https://bugzilla.mozilla.org/show_bug.cgi?id=877757#c22 I was able to obtain logging output. I was not enlightened, but I did notice:

RadioInterface[0]: We haven't gotten completely the APN data.

And that the network name is "Rogers Wireless". Normally for this sim it's "SpeakOut" which is a Rogers reseller and uses the Rogers APN.

In the 20131023 geeksphone build Settings::Call Settings and ::Cellular & Data both say "Unknown SIM card state" for this run. The bug above suggests this issue can be a RIL version mismatch.

Comment 7

4 years ago
(In reply to Ralph Giles (:rillian) from comment #6)
> Created attachment 821465 [details]
> radio.log
> 
> Following the instructions from
> https://bugzilla.mozilla.org/show_bug.cgi?id=877757#c22 I was able to obtain
> logging output. I was not enlightened, but I did notice:
> 
> RadioInterface[0]: We haven't gotten completely the APN data.
> 
> And that the network name is "Rogers Wireless". Normally for this sim it's
> "SpeakOut" which is a Rogers reseller and uses the Rogers APN.
> 
> In the 20131023 geeksphone build Settings::Call Settings and ::Cellular &
> Data both say "Unknown SIM card state" for this run. The bug above suggests
> this issue can be a RIL version mismatch.
Did you try to manually input APN data?
(Reporter)

Comment 8

4 years ago
The settings link was grayed out when they said "Unknown SIM card state". When they they don't say that (and I have voice/sms but no data) the APN settings from the db appear to be correct (rogers-core-appl1.apn).
(Reporter)

Comment 9

4 years ago
I flashed v1.2 20131202224512 from the the geeksphone site today, and can no longer reproduce. Looks like it got fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.