allow CGI arg with media link to maker [feature request]

RESOLVED FIXED

Status

Webmaker
Popcorn Maker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tracey jaquith, Assigned: mjschranz)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.69 Safari/537.36

Steps to reproduce:

if you could pass an url in to webmaker in an existing/new browser tab, something like:
https://popcorn.webmaker.org/?url=somevideo.mp4

that acted like the url was pasted into the media pane,
then offsite share / "add to Popcorn Maker" button would work nicely/ideally!
eg:
http://archive.org/~tracey/moz-plus.png




Actual results:

right now there is no way to do this


Expected results:

if done, it'll get more people using popcorn maker!  8-)
(Assignee)

Updated

4 years ago
Assignee: nobody → schranz.m
(Assignee)

Comment 1

4 years ago
Definitely a cool feature. We will do it for sure, although as much as I may want something like this in for Mozfest it won't be :(
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
This is def. a great, elegant idea.
(Assignee)

Comment 5

4 years ago
Well, the debate for the specific queryString param name is open but going with savedDataUrl wouldn't work because it matches an old URL structure.

I think initialMedia makes sense or at least it's a very "programmery" name.
(Reporter)

Comment 6

4 years ago
ok, cool.  we're all ready best I can tell then on this end (a flip and the "dev-only" version goes live, etc.)

If you'd like to see it now

https://www-tracey.archive.org/stream/COMW_20130726_023000_The_Daily_Show_With_Jon_Stewart/start/460/end/490?tv2=1

and look near the SHARE section for the image and link 8-)
Comment on attachment 828655 [details] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/298

I'm not too picky about the name, but yes, initialMedia is very programmerly.

I was thinking on just media, importMedia, src, but in the end decided it's not a big deal from my end.

This all looks good to me.
Attachment #828655 - Flags: review?(scott) → review+

Comment 8

4 years ago
Commit pushed to master at https://github.com/mozilla/popcorn.webmaker.org

https://github.com/mozilla/popcorn.webmaker.org/commit/d3b3acda98a1f605a33c0cf9b842f8a975894fe0
Fix Bug 928099 - Allow for an initial media to be set on blank project via query string.

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.