Make error messages in the curation tool more informative

RESOLVED DUPLICATE of bug 910099

Status

defect
RESOLVED DUPLICATE of bug 910099
6 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Pick a region/carrier combo which has an existing operator shelf
2. Try to create a new operator shelf for the same combo


observed behavior:
Collection creation fails with 'Failed to create new collection'. We should more informative error messages (like 'You can not have more than one Featured Apps/Operator Shelf collection for the same category/carrier/region combination')
I think we should prevent the "Add an Operator Shelf Collection" link from showing up if there's already one, but the error messages are going to get fixed in bug 910099.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910099
Per comment 1, re: preventing links - that's bug 921497.
You need to log in before you can comment on or make changes to this bug.