Closed Bug 928201 Opened 6 years ago Closed 6 years ago

Defect - Download app bar displays 'Run' for non-executable content

Categories

(Firefox for Metro Graveyard :: Downloads, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 28

People

(Reporter: jimm, Assigned: mbrubeck)

References

Details

(Whiteboard: [block28] feature=defect c=tbd u=tbd p=1)

Attachments

(3 files)

str:
1) visit a page with an image
2) press hold on image and select save to image library

result: download app bar displays with a Run button display and set as the default.
Summary: Download app bar displays 'Run' for non-executable content → Defect - Download app bar displays 'Run' for non-executable content
Whiteboard: [triage] → [triage] feature=defect c=tbd u=tbd p=0
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0
Whiteboard: feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=0
Hey Matt, can you provide a point estimate.
Assignee: nobody → mbrubeck
Blocks: metrov1it18
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Flags: needinfo?(mbrubeck)
Priority: -- → P2
QA Contact: jbecerra
p=1
Flags: needinfo?(mbrubeck)
Whiteboard: [block28] feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=1
Attached patch s/Run/Open/Splinter Review
This patch uses "Open" instead of "Run", for all downloaded files.

(Also includes a minor change to silence build warnings about preprocessing files in this directory that don't need to be preprocessed.)
Attachment #824720 - Flags: review?(msamuel)
Comment on attachment 824720 [details] [diff] [review]
s/Run/Open/

Review of attachment 824720 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/locales/en-US/chrome/browser.properties
@@ +58,4 @@
>  downloadSave=Save
>  downloadCancel=Cancel
>  downloadTryAgain=Try Again
> +downloadOpenNow=Open

Did you mean to have 'Open now' as the wording here? If not, can we just use the downloadOpen string and remove this?
Attachment #824720 - Flags: review?(msamuel) → review+
(In reply to Marina Samuel [:emtwo] from comment #4)
> Did you mean to have 'Open now' as the wording here?

Yes I did; thanks.  Fixed:
https://hg.mozilla.org/integration/fx-team/rev/c672c4cd6c7f
Err. So this was merged to central already. And then I backed it out because it broke all the mochitest-mc because Sidebar.js has a preprocessed license header, it was taken out of the preprocessed components list, and that broke metro startup.

Merge: https://hg.mozilla.org/mozilla-central/rev/c672c4cd6c7f
Backout: https://hg.mozilla.org/mozilla-central/rev/d8fd5706493e
https://hg.mozilla.org/mozilla-central/rev/7f907948d547
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Attached image screenshot.png
While testing this with the latest Nightly, for iteration #18, I get the following:

1) the image is saved on disk, in Libraries\Pictures

2) the app bar shows that a download was made (for more details please see the attached screenshot)

Is this the intended behavior? Thanks!
Flags: needinfo?(mbrubeck)
(In reply to Manuela Muntean [:Manuela] [QA] from comment #9)
> 1) the image is saved on disk, in Libraries\Pictures
> 
> 2) the app bar shows that a download was made (for more details please see
> the attached screenshot)
> 
> Is this the intended behavior? Thanks!

Yes, that's expected.  Additionally, there should be notification bars that appear during and after the download.  If they aren't appearing, it might be because of bug 936897.
Flags: needinfo?(mbrubeck)
Attached image screenshot 2.png
Verified as fixed, for iteration #18, on Win 8 64-bit, with latest Nightly (build ID: 20131115030203).

I can see the notification bar shown in the attached screenshot.
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.