Closed Bug 928204 Opened 6 years ago Closed 6 years ago

Missing dependencies on make binaries builds

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla27

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files, 1 obsolete file)

STR:
- mach clobber
- mach build
- touch js/src/jsapi.cpp
- mach build binaries

Expected result:
- rebuilt js/src/shell/js binary, as well as some others

Observed result:
- js/src/shell/js not rebuilt.

It however happens on subsequent rebuilds.

This looks to be due to the $(wildcard) in the binaries rule in config/recurse.mk.
Depends on: 664362
However, since we don't generate depfiles when compiling assembly, explicitly exclude those.
Also, fix a few issues with included depfiles:
- The tools tier need them because it (sadly) links binaries.
- depfiles for TARGETS use the full path, whereas the depfiles for OBJS and others don't.

https://tbpl.mozilla.org/?tree=Try&rev=612e3bac258a
Attachment #818966 - Flags: review?(gps)
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Comment on attachment 818966 [details] [diff] [review]
Don't ignore missing depfiles when aggregating them

Review of attachment 818966 [details] [diff] [review]:
-----------------------------------------------------------------

These make blocks are impossibly hard to read. But, this is not part of the official build and I trust any issues will surface quickly.
Attachment #818966 - Flags: review?(gps) → review+
backed out this change since it caused failing builds on linux pgo like https://tbpl.mozilla.org/php/getParsedLog.php?id=29478112&tree=Mozilla-Inbound
Attached patch Fixup (obsolete) — Splinter Review
This is an interdiff to fix the problem with pgo builds ; i'll reland this folded in the previous patch. I also attempted to make the link_deps command more intelligible by making it shorter.
Attachment #820739 - Flags: review?(gps)
Comment on attachment 820739 [details] [diff] [review]
Fixup

What am i smoking, this doesn't work.
Attachment #820739 - Attachment is obsolete: true
Attachment #820739 - Flags: review?(gps)
Attached patch FixupSplinter Review
This works.
Attachment #820748 - Flags: review?(gps)
Duplicate of this bug: 929460
Duplicate of this bug: 928732
Attachment #820748 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/b854380d2c35
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Depends on: 1041381
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.