Error launching messenger chrome from command line

VERIFIED INVALID

Status

SeaMonkey
MailNews: Message Display
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: Becki Sanford, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.4.0-test10 i686)
BuildID:    Mozilla 0.9.2 and nightly 2001073008

Get the following error if Mozilla is launched from the command line as a chrome
(./mozilla -chrome chrome://messenger/content/):

Error hiding AccountCentral page -> TypeError: threadPaneBox has no properties

Same thing occurs if attempt to launch mail from JavaScript with the following
code:

window.openDialog("chrome://messenger/content/,"_blank","chrome,dialog=no,all");

Reproducible: Always
"./mozilla -chrome chrome://messenger/content/"  isn't supported.

do "mozilla -mail"

if anything, you want to do this:

"./mozilla -chrome chrome://messenger/content/messenger.xul" 

or 

"chrome://messenger/content/mail3PaneWindowVertLayout.xul"

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

17 years ago
./mozilla -chrome chrome://messenger/content/messenger.xul gives the specified
error message but the second one appears to work.

Just wanted to know why that that error message appears...
ok, when launching with the -chrome url, I get that error too.

and, in the 3 pane that comes up I don't get account central when I select a
server in the folder pane, which is bad.

what are you trying to do? 

if opening from the cmd line, use -mail.  if opening from .js, follow
MsgOpenNewWindowForFolder() in mailWindowOverlay.js

if you still have problems, please reopen the bug, because then something that
is supported is broken .
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 4

17 years ago
Ahhh... I see that I need to specify the right XUL based on the mail.pane_config
preference.  It doesn't like launching messenger.xul when the pane_config is set
to 1; in that case, I should be launching with mail3PaneWindowVertLayout.xul

Marking the bug as INVALID.  Sorry for the hassle.  Please resume your normal
Mozilla activities...
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
Mark it verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.