Closed Bug 928258 Opened 8 years ago Closed 8 years ago

VS2012 Express Update 3: C:\msvc11\VC\INCLUDE\xkeycheck.h(87) : fatal error C1189: #error

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 7
defect
Not set
blocker

Tracking

(firefox27+ fixed)

RESOLVED DUPLICATE of bug 928091
Tracking Status
firefox27 + fixed

People

(Reporter: WeirdAl, Unassigned)

References

Details

From build output:
14:52.47 aes_icm.c
14:52.47 Warning: C4005 in C:\msvc11\VC\INCLUDE\xkeycheck.h: 'inline' : macro redefinition
14:52.47 C:\msvc11\VC\INCLUDE\xkeycheck.h(65) : warning C4005: 'inline' : macro redefinition
14:52.47         command-line arguments :  see previous definition of 'inline'
14:52.47 C:\msvc11\VC\INCLUDE\xkeycheck.h(87) : fatal error C1189: #error :  The C Standard Library forbids macroizing keywords. Enable warning C4005 to find the forbidden macro.

I'm building Mozilla Firefox from mozilla-central, almost clean tree, haven't touched anything near aes_icm.c.  I previously hit this problem with libopus code in the tree, but --disable-opus wallpapered over that.  There it complained about 'inline' and 'restrict' macros.

mozconfig:
#
# See http://www.mozilla.org/build/ for build instructions.
#

. $topsrcdir/browser/config/mozconfig

# Options for client.mk.
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../fx-debug

# Options for 'configure' (same as command-line options).
ac_add_options --disable-activex
ac_add_options --disable-activex-scripting
ac_add_options --disable-xpconnect-idispatch
ac_add_options --enable-debug
ac_add_options --disable-optimize
ac_add_options --enable-tests
ac_add_options --disable-crashreporter
ac_add_options --disable-accessibility
ac_add_options --disable-javaxpcom
ac_add_options --disable-opus

Filed as blocker:  I can't build.  cc'ing patch authors per hg blame and ted as reviewer on both patches.
Depends on: 792325, 674225
Same issue with -Dinline=__inline as Opus has...
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928091
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.