Source line break inserted between </a> and punctuation

VERIFIED DUPLICATE of bug 98031

Status

()

Core
Serializers
P3
normal
VERIFIED DUPLICATE of bug 98031
17 years ago
17 years ago

People

(Reporter: hsivonen, Assigned: Brade)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serializer])

(Reporter)

Description

17 years ago
Steps to reproduce.
1) Select "Paragraph" from the block menu
2) Type: "foo."
3) Linkify "foo"
4) Take a look at the HTML source view and notice the line break between "</a>"
and "."
5) Click "Browse" in the toolbar.

Actual results:
On the browser side the source line break shows up (as a space as expected when
there is a line break in the source).

Expected results:
Expected Editor to not add a line break between a closing inline tag and
punctuation.

Comment 1

17 years ago
1.0
Assignee: beppe → jfrancis
Priority: -- → P3
Whiteboard: [rules]
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
All platforms.
OS: MacOS X → All
Hardware: Macintosh → All

Comment 3

17 years ago
uuhhh, this is the serializer.  Thats why you dont see the space in composer, 
unless you save and reopen, etc.  Who owns the serializer?
Assignee: jfrancis → brade
(Assignee)

Updated

17 years ago
Whiteboard: [rules] → [serializer]

Comment 4

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer
(Assignee)

Comment 5

17 years ago


*** This bug has been marked as a duplicate of 98031 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Component: Editor: Composer → DOM to Text Conversion
Resolution: --- → DUPLICATE

Comment 6

17 years ago
marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.