Closed Bug 928358 Opened 9 years ago Closed 9 years ago

Update pdf.js to version 0.8.629

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 27

People

(Reporter: ryanvm, Assigned: ryanvm)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #922693 +++

Changes since the last update:
#3643 Change the cursor so that text selection doesn't appear possible in presentation mode
#3728 Added missed space in Czech translation
#3752 Move Presentation Mode related code from viewer.js to its own file
#3738 Transposed feature for text decoding in jbig2
#3757 Move Settings from viewer.js to its own file
#3746 [B2G] Remove the remaining occurrences of -webkit prefixes from the CSS
#3750 Proper glyph selection for CIDFontType0C fonts.
#3582 Set URL in history.replaceState/pushState
#3739 Add the viewBookmark button to the Secondary Toolbar
#3759 Fix external links in Presentation Mode (issue 3755)
#3763 Refactor Presentation Mode code
#3778 Update ja locale
#3779 Update zh-TW locale
#3670 Polyfill for mozPrintCallback
#3774 Enabling clicking to close the context menu in Presentation Mode, without going to the next page
#3727 Use css to initially scale on zoom.
#3790 Trivial typo fix
#3776 Refactoring thumbnail scroll code to fix jumps
#3777 Fix hiding of the cursor in Presentation Mode in WebKit browsers
#3764 Simplify get fingerprint() method
#3801 chrome.extension -> chrome.runtime for Ubuntu
#3807 chrome.runtime -> chrome.extension when needed (support Chromium 20-25)
#3787 Inline setScale in parseScale
#3796 Add missing jsdocs for PDFJS globals.
#3810 Minor nit fixes for api.js
#3577 Implement initial CalGray support
#3751 [Chrome extension] Change PDF rendering method.
#3794 Fix the B2G viewer and enable bot preview.
#3822 Fix bot breakage caused by Chromium extension PR
#3821 Decrease dependence of SecondaryToolbar on UI buttons
#3791 Fix css rotation for canvas and text layer.
Attached patch 928358Splinter Review
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #818983 - Flags: review?(ydelendik)
Comment on attachment 818983 [details] [diff] [review]
928358

Review of attachment 818983 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good
Attachment #818983 - Flags: review?(ydelendik) → review+
https://hg.mozilla.org/mozilla-central/rev/5def33b076d6
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Blocks: 931246
Blocks: 752219
Depends on: 1020878
No longer blocks: 931246
Type: defect → task
No longer depends on: 922693
You need to log in before you can comment on or make changes to this bug.