Document assumes I have XCode installed, but doesn't say it explicitly

RESOLVED FIXED

Status

Developer Documentation
Firefox OS
P5
normal
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Aleksandr Motsjonov, Assigned: sheppy)

Tracking

Details

(Whiteboard: c=FirefoxOS u=mozdev p=0, URL)

(Reporter)

Description

4 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: eshepherd@mozilla.com

:: Details

soswow: So, If I don't need to have Xcode, then why it should be /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/ here ?
[9:47pm] sheppy: I know there are some things that are out of date now
[9:47pm] soswow: I mean I don't event have /Applications/Xcode.app
[9:47pm] sheppy: soswow: The docs generally assume that you did go ahead and install Xcode, because most Mac devs will do so
[9:47pm] sheppy: It's far and away the easiest way to do this.
[9:48pm] soswow: I am a mac user and developer. I never did Mac Native development, so I don't need Xcode.
[9:48pm] soswow: And if something in the doc assume I should have this - then it should say so, what do you think? 
[9:49pm] sheppy: soswow: probably true. Could you file a doc bug? https://bugzilla.mozilla.org/form.doc
(Reporter)

Updated

4 years ago
(Assignee)

Comment 1

2 years ago
Article now specifically says you need to install Xcode. I also corrected the capitalization from "XCode" to "Xcode" throughout the article while I was at it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.