Screenshot overlappery during app submission

VERIFIED FIXED in 2013-10-21

Status

Marketplace
Developer Pages
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Assigned: mat)

Tracking

({regression})

2013-10-21
regression
Points:
---

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 819186 [details]
screenshot uploaded.png

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/submit/details/test-webapi-permissions-7
2. Upload a screenshot



observed behavior:
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/submit/details/test-webapi-permissions-7
2. Upload a screenshot



observed behavior:
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/submit/details/test-webapi-permissions-7
2. Upload a screenshot



observed behavior:
Screenshot overlappery during app submission. See screenshot.
Basta regressed this
(Assignee)

Comment 2

4 years ago
Or me in 928287. Or basta+me. I removed a min-height which I thought was no longer necessary and causing other issues with landscape screenshots. It looks like there is still a float somewhere causing issues.
(Assignee)

Comment 3

4 years ago
Looked at it briefly, it's actually a position: absolute. At first glance it looks like we can do without, we'd just need to correctly place the error text when there is one. 

FWIW, re-ordering seems not broken atm, but we should keep an eye on it and test with the edit page as well when we fix this.
(Assignee)

Comment 4

4 years ago
Fixed in https://github.com/mozilla/zamboni/commit/f50cc2b1306db533d79680fe5492c142c29801a9

More complete STR to make sure there are no regressions left:

- Start app submission process on -dev
- When submitting, upload a valid screenshot in portrait, another in landscape
- Also upload a landscape and portrait image with wrong dimensions (e.g. a 200x700 image and a 700x200 image)
- Verify that nothing overlaps, that the error messages are correctly displayed, that the re-order handles on the right of the screenshots are correctly visible
- Verify that you are able to properly re-order screenshots

AND

- Edit media for an existing app on -dev
- Verify that the same steps described above also work fine when editing.
Assignee: nobody → mpillard
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Priority: -- → P2
Resolution: --- → FIXED
(Reporter)

Comment 5

4 years ago
verified fixed all the above listed scenarios. See post-fix screenshots.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

4 years ago
Created attachment 820067 [details]
post-fix screenshot-submission
(Reporter)

Comment 7

4 years ago
Created attachment 820068 [details]
post-fix screenshot- edit
You need to log in before you can comment on or make changes to this bug.