Scroll bar can not hide on latest Nightly as of 20131018

VERIFIED FIXED in Firefox 26

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: nayinain, Assigned: roc)

Tracking

({regression})

27 Branch
mozilla27
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox24 unaffected, firefox25 unaffected, firefox26 fixed, firefox27+ verified, b2g-v1.2 fixed)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

Posted file test.html
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131018030206

Steps to reproduce:

1. Open the test.html file
2. Click the "+" button


Actual results:

The bottom of the scroll bar appeared in the step 2.


Expected results:

Scroll bar is always hidden.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/423b9c30c73d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017030201
Bad:
http://hg.mozilla.org/mozilla-central/rev/4e7d1e2c93a6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131018030206


Sorry for my bad English.
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9c8ab7e9ae41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017025216
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/45d9e6cd3473
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017030414
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9c8ab7e9ae41&tochange=45d9e6cd3473

Suspected: Bug 926706
Blocks: 926706
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
roc - what's your read on this? I can't tell whether a large segment of the web would be impacted.
Flags: needinfo?(roc)
I'm not sure but we should definitely fix it before release.
Flags: needinfo?(roc)
Posted patch fix (obsolete) — Splinter Review
Assignee: nobody → roc
Attachment #820308 - Flags: review?
Attachment #820308 - Flags: review? → review?(tnikkel)
Comment on attachment 820308 [details] [diff] [review]
fix

It looks like IsCollapsed() is only relevant in the XUL case at least.
I don't think this is ready to land.
Oops.

(In reply to Timothy Nikkel (:tn) from comment #5)
> It looks like IsCollapsed() is only relevant in the XUL case at least.

What's wrong with just calling it?
BTW this caused reftest failure:
https://tbpl.mozilla.org/php/getParsedLog.php?id=29555168&tree=Mozilla-Inbound&full=1#error0
I plan to just fuzz the test on Mac. I think this is a longstanding issue where the edges of invalidated areas are sometimes off by 1/255 on Mac.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #9)
> Oops.
> 
> (In reply to Timothy Nikkel (:tn) from comment #5)
> > It looks like IsCollapsed() is only relevant in the XUL case at least.
> 
> What's wrong with just calling it?

You can call it, but it looks like it should only be used here in the XUL collapsed sense, and not the table part collapsed sense.
This code blocks comes from bug 524925 where it looks like it as pulled from nsBox::SyncLayout. And that chunk of code in nsBox::SyncLayout is only executed on frames for which ComputesOwnOverflowArea() is false. And it seems that only some XUL frames have ComputesOwnOverflowArea() return false.
Posted patch fix v2Splinter Review
Attachment #820308 - Attachment is obsolete: true
Attachment #820308 - Flags: review?(tnikkel)
Attachment #822364 - Flags: review?
Attachment #822364 - Flags: review? → review?(tnikkel)
Attachment #822364 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/8631813be2e1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Keywords: verifyme
Looks good to me. Build ID: 20131028040205
Status: RESOLVED → VERIFIED
Keywords: verifyme
Comment on attachment 822364 [details] [diff] [review]
fix v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: column flicker - bug 917060
Testing completed (on m-c, etc.): on m-c since 2013-10-26, also in Aurora(27)
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch: none

Landing bug 926706 and bug 928607 on Beta(26) to fix/wallpaper bug 917060
should be straightforward and lower risk than backing out what caused that bug.
Attachment #822364 - Flags: approval-mozilla-beta?
Attachment #822364 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
changing 26 to 'affected' since we'll be landing this there and it shouldn't state 'unaffected'
You need to log in before you can comment on or make changes to this bug.