Firefox Nightly crashes with Firefox Marketplace open [@ memcpy | waveOutGetDevCapsA]

VERIFIED FIXED in Firefox 27

Status

()

Core
General
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ntim, Assigned: kinetik)

Tracking

({crash, regression, topcrash-win})

27 Branch
mozilla27
x86_64
Windows NT
crash, regression, topcrash-win
Points:
---

Firefox Tracking Flags

(firefox27+ fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131018030206

Steps to reproduce:

Open Firefox Nightly
Open http://marketplace.firefox.com


Actual results:

It crashed (even in Safe Mode)


Expected results:

It shouldn't have crashed
(Reporter)

Comment 1

4 years ago
Crash report bp-ea828a84-c8d9-4916-a11b-f465a0fe7860 (not sure if it's the right one)
(Reporter)

Comment 2

4 years ago
Newer crash report : bp-95d24ef1-10b7-402e-b23c-553a42131019
(Reporter)

Comment 3

4 years ago
Also happening with a clean profile.

Comment 4

4 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/855da6d8a327
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017044622
Bad:
http://hg.mozilla.org/mozilla-central/rev/2def80d5a106
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131018023712
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=855da6d8a327&tochange=2def80d5a106

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/616980966644
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017070815
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6ca71aca6e9e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017072215
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=616980966644&tochange=6ca71aca6e9e

Suspected: Bug 922247, Bug 918861, Bug 907817
Severity: normal → critical
Status: UNCONFIRMED → NEW
tracking-firefox27: --- → ?
Component: Untriaged → General
Ever confirmed: true
Keywords: crash, regression
Product: Firefox → Core

Comment 5

4 years ago
In local build 
Last Good: ac461ea5f961
First Bad: 8c159c637fdb

Triggered by:
8c159c637fdb	Paul Adenot — Bug 918861 - Allow the MSG to choose a better samplerate than 48000Hz. r=roc
Blocks: 918861
(Assignee)

Updated

4 years ago
Assignee: nobody → kinetik
(Assignee)

Comment 6

4 years ago
Created attachment 819516 [details] [diff] [review]
bug928615_v0.patch

Try push: https://tbpl.mozilla.org/?tree=Try&rev=d830ebf5e435
Attachment #819516 - Flags: review?(paul)
Comment on attachment 819516 [details] [diff] [review]
bug928615_v0.patch

Review of attachment 819516 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry :/
Attachment #819516 - Flags: review?(paul) → review+

Updated

4 years ago
Duplicate of this bug: 928951

Updated

4 years ago
Crash Signature: [@ memcpy | waveOutGetDevCapsA]
Summary: Firefox Nightly crashes with Firefox Marketplace open → Firefox Nightly crashes with Firefox Marketplace open [@ memcpy | waveOutGetDevCapsA]

Updated

4 years ago
Keywords: topcrash-win
Pushed an updated patch to try: http://tbpl.mozilla.org/?tree=Try&rev=c7427bf9e8c6
(Assignee)

Comment 10

4 years ago
That failure is odd.  Pushed some more debug logging: https://tbpl.mozilla.org/?tree=Try&rev=7856e24cfcb3
(Assignee)

Comment 11

4 years ago
Heh, the signature for winmm_get_preferred_sample_rate was wrong. :-(

https://tbpl.mozilla.org/?tree=Try&rev=b0ea2ecae631
(Assignee)

Comment 12

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c442591daec0
https://hg.mozilla.org/mozilla-central/rev/c442591daec0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27

Updated

4 years ago
status-firefox27: --- → affected
tracking-firefox27: ? → +

Updated

4 years ago
Duplicate of this bug: 929962

Comment 15

4 years ago
https://marketplace.firefox.com/ no longer causes a crash on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131023030205 CSet: 21d97baadc05

Thanks for the prompt fix =)
Status: RESOLVED → VERIFIED

Updated

4 years ago
Duplicate of this bug: 929906
(Assignee)

Updated

4 years ago
status-firefox27: affected → fixed
You need to log in before you can comment on or make changes to this bug.