Closed Bug 928620 Opened 8 years ago Closed 8 years ago

[Buri][Data usage]Set the phone and internet data report is abnormal.

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect, P2)

defect

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.3 C3/1.4 S3(31jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: sync-1, Assigned: mai)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

31.55 KB, image/png
Details
20.52 KB, application/octet-stream
Details
46 bytes, text/x-github-pull-request
salva
: review+
Details | Review
Firefox os  v1.1
 Mozilla build ID:20130916041201
 
 Created an attachment (id=537266)
 picture
 
 DEFECT DESCRIPTION:
  Set the phone and internet data report as Monthly or weekly,the usage display abnormal.
 
  REPRODUCING PROCEDURES:
  1.set the report ,select monthly and starting on 31,select done,look at the usage display,the mobile/wifi usage diaplay normally.--OK
  2.usage setting-->reset report-->weekly,don't need select the starting on,select done,look at the usage display,the mobile/wifi usage don't display.-->KO(you can see the error result like the picture)
 
  EXPECTED BEHAVIOUR:
  reset the report the usage display correctly
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:mid
 
  REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:
Attached image picture
Clone from brother
Attached file logcat.log
Clone from brother
Indeed, the bug reproduces if you change from monthly to weekly but NOT set the starting day. What should we do? This reproduces in master as well.
Flags: needinfo?(marce)
Too late for 1.1, we should do it in version 1.3
blocking-b2g: --- → 1.3?
Flags: needinfo?(marce)
blocking-b2g: 1.3? → 1.3+
Keywords: regression
Assignee: nobody → mri
Attached file patch v1.0
Please, could you review the code?

Regards
Attachment #8361068 - Flags: review?(salva)
Comment on attachment 8361068 [details] [review]
patch v1.0

Despite it breaks compatibility with already configured SIMs, I think we are over sizing the fixing. Let's talk to see how to address this problem.

Thank you anyway for all the well done work.
Attachment #8361068 - Flags: review?(salva) → review-
PM triaged this bug and believe it should be a blocker.
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
Comment on attachment 8361068 [details] [review]
patch v1.0

Please, could you review the new patch?
Regards
Attachment #8361068 - Flags: review- → review?(salva)
Blocks: 951074
Comment on attachment 8361068 [details] [review]
patch v1.0

Working fine. Thank you!
Attachment #8361068 - Flags: review?(salva) → review+
Master: c4fd0e7f2106af0d57f385ea3a7753c331850555
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Uplifted c4fd0e7f2106af0d57f385ea3a7753c331850555 to:
v1.3: 7f94df268a3f0351659e73a4cc5183c9fdd94be8
Flags: in-testsuite?
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.