Find Toolbar doesn't find next occurrence the first time you click the Find Next toolbarbutton

RESOLVED DUPLICATE of bug 922040

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 922040
4 years ago
4 years ago

People

(Reporter: mcdavis941 (sporadically reading bugmail), Unassigned)

Tracking

Trunk
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I think there's a problem with the Find Toolbar.  The problem is that clicking the Find Next button refinds the first occurrence instead of jumping to the next occurrence.

STR: 
1 - Open some page in a new tab e.g. https://bugzilla.mozilla.org/show_bug.cgi?id=896768 .
2 - Press cttl-F to open the Find Toolbar.
3 - Enter some string that exists multiple times on the page (for the example Bugzilla page, the string "hg.", without the quotes).
4 - Notice that the first occurrence is found and highlighted.
5 - Press the Find Next button in the Find Toolbar.
6 - Notice that the first occurrence is again found and highlighted.

Expected results:
- the Find Next button finds the following occurrence

Actual results:
- the Find Next button finds the first occurrence again rather than the following one

I think I first noticed this very roughly around the time the Findbar was moved to the top then back to the bottom; however, right now, I can only repro this on trunk.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 922040
You need to log in before you can comment on or make changes to this bug.