Truncated window title with accented chars

VERIFIED FIXED in mozilla0.9.6

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: marina, Assigned: nhottanscp)

Tracking

({intl})

Trunk
mozilla0.9.6
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I am seeing this on JA system when displaying a message, same message displayed
on WinNT JA doesn't have this problem: chars have no accents but they are not
truncated
Steps to reproduce:
- log into to the account;
- select a message with accented chars , say "umlaut"jet";
- now notew: the window title displays only "s" the part that starts with
accented chars is truncated. If the message header starts with accented chars it
won't be displayed at all. Again on WinNT JA the caption doesn't show any
accents though it doesn't truncate the string

Comment 1

17 years ago
marna: Is this Mail/News specific?
cc'ing nhotta, ftang.

Comment 2

17 years ago
Mac issue, assigning to ftang.
Assignee: yokoyama → ftang
(Reporter)

Comment 3

17 years ago
It is specific Mac issue but not limited to Mail/News. You can see the same
happening in the browser window when going to any page from netscape.fr that has
accented chars in the link. The window title would display truncated

Updated

17 years ago
Keywords: intl
(Reporter)

Comment 4

17 years ago
qa to myself
QA Contact: ji → marina

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 5

17 years ago
mark m95
Target Milestone: --- → mozilla0.9.5

Updated

17 years ago
Priority: -- → P3

Comment 6

17 years ago
give to nhotta, I believe now this is MacOS 9 only, right ?
I think the problem is in 
widget/src/mac/nsMacControl.cpp
406 void nsMacControl::StringToStr255(const nsString& aText, Str255& aStr255)
Call 
mUnicodeEncoder->->SetOutputErrorBehavior(nsIUnicodeEncoder::kOnError_Replace, 
nsnull, (PRUnichar)'?');

probably will fix this problem. 
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 7

17 years ago
give to nhotta
Assignee: ftang → nhotta
Status: ASSIGNED → NEW
(Assignee)

Comment 8

17 years ago
Created attachment 52833 [details] [diff] [review]
Patch, added nsIUnicodeEncoder::SetOutputErrorBehavior to avoid the truncation.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 9

17 years ago
Comment on attachment 52833 [details] [diff] [review]
Patch, added nsIUnicodeEncoder::SetOutputErrorBehavior to avoid the truncation.

r=ftang
Attachment #52833 - Flags: review+

Comment 10

17 years ago
sr=sfraser
Hardware: PC → Macintosh
(Assignee)

Comment 11

17 years ago
Checked in to the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

17 years ago
verified with 2001-11-01 trunk build, the window title is not truncated anymore
neither in mail nor in browser
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.